summaryrefslogtreecommitdiff
path: root/build-aux/hydra/guix.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-18 19:00:03 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-18 19:00:13 +0200
commit37c0ce3d279450d5f33f7bc405989c570249f032 (patch)
treef86e4fdbaf422022dfe22a83680997114688842f /build-aux/hydra/guix.scm
parent59688fc4b5cfac3e05610195a47795f5cc15f338 (diff)
downloadguix-patches-37c0ce3d279450d5f33f7bc405989c570249f032.tar
guix-patches-37c0ce3d279450d5f33f7bc405989c570249f032.tar.gz
hydra: Point the Git submodule to our local copy.
* build-aux/hydra/guix.scm (tarball-package): Add 'nix-checkout' parameter. Replace 'patch-bootstrap-script' phase by 'set-nix-module'. (hydra-jobs): Get the 'nix' value from ARGUMENTS, and pass it to 'tarball-package'.
Diffstat (limited to 'build-aux/hydra/guix.scm')
-rw-r--r--build-aux/hydra/guix.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/build-aux/hydra/guix.scm b/build-aux/hydra/guix.scm
index dbc935d897..59e3172e1f 100644
--- a/build-aux/hydra/guix.scm
+++ b/build-aux/hydra/guix.scm
@@ -63,7 +63,7 @@
(home-page . ,(package-home-page package))
(maintainers . ("bug-guix@gnu.org"))))
-(define (tarball-package checkout)
+(define (tarball-package checkout nix-checkout)
"Return a package that does `make distcheck' from CHECKOUT, a directory
containing a Git checkout of Guix."
(let ((dist (dist-package guix checkout)))
@@ -72,12 +72,12 @@ containing a Git checkout of Guix."
(arguments (substitute-keyword-arguments (package-arguments dist)
((#:phases p)
`(alist-cons-before
- 'autoreconf 'patch-bootstrap-script
+ 'autoreconf 'set-nix-submodule
(lambda _
- ;; Comment out `git' invocations, since Hydra provides
- ;; us with a checkout that includes sub-modules.
- (substitute* "bootstrap"
- (("git ") "true git ")))
+ ;; Tell Git to use the Nix checkout that Hydra gave us.
+ (zero?
+ (system* "git" "config" "submodule.nix-upstream.url"
+ nix-checkout)))
,p))))
(native-inputs `(("git" ,git)
("graphviz" ,graphviz)
@@ -99,8 +99,12 @@ containing a Git checkout of Guix."
(define checkout
(assq-ref arguments 'guix))
- (format (current-error-port) "using checkout ~s~%" checkout)
+ (define nix-checkout
+ (assq-ref arguments 'nix))
+
+ (format (current-error-port) "using checkout ~s (Nix: ~s)~%"
+ checkout nix-checkout)
(let ((directory (assq-ref checkout 'file-name)))
`((tarball . ,(cute package->alist store
- (tarball-package directory)
+ (tarball-package directory nix-checkout)
(%current-system))))))