summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-06-23 22:43:00 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-23 23:35:27 +0200
commitef82ba9dd94369926eb13325d5e7da4306d23dd7 (patch)
tree7b37fe66dd4088556ad41dcbf7745c6e9b24f501 /Makefile.am
parenta807d849219c34d45310634ef0cfc94ad9b7025a (diff)
downloadguix-patches-ef82ba9dd94369926eb13325d5e7da4306d23dd7.tar
guix-patches-ef82ba9dd94369926eb13325d5e7da4306d23dd7.tar.gz
build: Makefile splits Scheme compilation in four steps.
Fixes <https://bugs.gnu.org/48963>. Reported by Julien Lepiller <julien@lepiller.eu>. This reduces peak memory consumption to something less unreasonable. * Makefile.am (make-go): Depend on 'make-*-go' targets; remove body. (guile-compilation-rule): New function. (MODULES_CORE, MODULES_PACKAGES, MODULES_SYSTEM, MODULES_CLI): New variables. <top level>: Call 'guile-compilation-rule' 4 times. * build-aux/compile-all.scm <top level>: Expect "--total" and "--processed". Take them into account when displaying progress reports.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am56
1 files changed, 47 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index aa21b5383b..7bb5de007e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -663,15 +663,53 @@ CLEANFILES = \
# the whole thing. Likewise, set 'XDG_CACHE_HOME' to avoid loading possibly
# stale files from ~/.cache/guile/ccache.
%.go: make-go ; @:
-make-go: $(MODULES) guix/config.scm $(dist_noinst_DATA)
- $(AM_V_at)echo "Compiling Scheme modules..." ; \
- unset GUILE_LOAD_COMPILED_PATH ; \
- XDG_CACHE_HOME=/nowhere \
- host=$(host) srcdir="$(top_srcdir)" \
- $(top_builddir)/pre-inst-env \
- $(GUILE) -L "$(top_builddir)" -L "$(top_srcdir)" \
- --no-auto-compile \
- -s "$(top_srcdir)"/build-aux/compile-all.scm $^
+make-go: make-core-go make-packages-go make-system-go make-cli-go
+
+# Define a rule to build a subset of the .go files.
+define guile-compilation-rule
+
+$(1): $(2)
+ $(AM_V_at)echo "Compiling Scheme modules..." ; \
+ unset GUILE_LOAD_COMPILED_PATH ; \
+ XDG_CACHE_HOME=/nowhere \
+ host=$(host) srcdir="$(top_srcdir)" \
+ $(top_builddir)/pre-inst-env \
+ $(GUILE) -L "$(top_builddir)" -L "$(top_srcdir)" \
+ --no-auto-compile \
+ -s "$(top_srcdir)"/build-aux/compile-all.scm \
+ --total $(words $(MODULES)) \
+ --completed $(3) \
+ $$(filter %.scm,$$^)
+
+.PHONY: $(1)
+
+endef
+
+# Split compilation in several steps, each of which building a subset of
+# $(MODULES). The main goal is to reduce peak memory consumption, as reported
+# in <https://issues.guix.gnu.org/48963>. Each 'eval' call below creates a
+# 'make-*-go' phony target that builds the corresponding subset.
+
+MODULES_CORE = $(filter-out guix/scripts/%,$(filter guix/%,$(MODULES)))
+MODULES_PACKAGES = $(filter gnu/packages/%,$(MODULES))
+MODULES_SYSTEM = $(filter-out gnu/packages/%,$(filter gnu/%,$(MODULES)))
+MODULES_CLI = $(filter guix/scripts/%,$(MODULES))
+
+$(eval $(call guile-compilation-rule,make-core-go, \
+ $(MODULES_CORE) guix/config.scm $(dist_noinst_DATA), \
+ 0))
+
+$(eval $(call guile-compilation-rule,make-packages-go, \
+ $(MODULES_PACKAGES) make-core-go, \
+ $(words $(MODULES_CORE))))
+
+$(eval $(call guile-compilation-rule,make-system-go, \
+ $(MODULES_SYSTEM) make-packages-go make-core-go, \
+ $(words $(MODULES_CORE) $(MODULES_PACKAGES))))
+
+$(eval $(call guile-compilation-rule,make-cli-go, \
+ $(MODULES_CLI) make-system-go make-packages-go make-core-go, \
+ $(words $(MODULES_CORE) $(MODULES_PACKAGES) $(MODULES_SYSTEM))))
SUFFIXES = .go