summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2014-03-29 00:06:41 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-30 12:02:10 +0200
commite9c6c58418043f36862a798389f3a7f4253f74cc (patch)
treec356b60c18a2aa02284dc565f6671f95f86fe8fb /Makefile.am
parent24194b6b543427510766813fdce01cfb79d00651 (diff)
downloadguix-patches-e9c6c58418043f36862a798389f3a7f4253f74cc.tar
guix-patches-e9c6c58418043f36862a798389f3a7f4253f74cc.tar.gz
substitute-binary: Support the Signature field of a narinfo file.
* guix/scripts/substitute-binary.scm (<narinfo>): Add the 'signature' and 'contents' fields. (narinfo-signature->canonical-sexp): New function. (narinfo-maker): Add the 'signature' argument and use it. (assert-valid-signature): New function. (read-narinfo): Support the Signature field. (write-narinfo): Use 'narinfo-contents'. (%allow-unauthenticated-substitutes?): New variable. * guix/base64.scm, tests/base64.scm, tests/substitute-binary.scm: New files. * Makefile.am (SCM_TESTS): Add tests/base64.scm and tests/substitute-binary.scm. (MODULES): Add guix/base64.scm. * test-env.in: Set 'GUIX_ALLOW_UNAUTHENTICATED_SUBSTITUTES'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0eb9a834dc..9f003c9fba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,7 @@ include gnu-system.am
MODULES = \
guix/base32.scm \
+ guix/base64.scm \
guix/records.scm \
guix/hash.scm \
guix/pk-crypto.scm \
@@ -122,9 +123,11 @@ clean-go:
SCM_TESTS = \
tests/base32.scm \
+ tests/base64.scm \
tests/hash.scm \
tests/pk-crypto.scm \
tests/pki.scm \
+ tests/substitute-binary.scm \
tests/builders.scm \
tests/derivations.scm \
tests/ui.scm \