summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-01-08 14:51:13 -0600
committerEric Bavier <bavier@member.fsf.org>2015-01-09 10:38:26 -0600
commitd45dc6da5c802024f31dba95919c06205c5e31e4 (patch)
treecea230023a562edb0fc474eb47cc92692926ad25 /Makefile.am
parent694b317c2dfac5f8b284a5831e20d89cc112bd6b (diff)
downloadguix-patches-d45dc6da5c802024f31dba95919c06205c5e31e4.tar
guix-patches-d45dc6da5c802024f31dba95919c06205c5e31e4.tar.gz
import: Add CPAN importer.
* guix/import/cpan.scm, guix/scripts/import/cpan.scm, tests/cpan.scm: New files. * Makefile.am (MODULE)[HAVE_GUILE_JSON]: Add them. * guix/scripts/import.scm (importers): Add cpan. * doc/guix.texi (Requirements): Mention `guix import cpan` as a user of guile-json. (Invoking guix import): Document new `guix import cpan` command.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c2bb1762ff..5ee743470b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -176,9 +176,13 @@ if HAVE_GUILE_JSON
MODULES += \
guix/import/json.scm \
guix/import/pypi.scm \
- guix/scripts/import/pypi.scm
+ guix/scripts/import/pypi.scm \
+ guix/import/cpan.scm \
+ guix/scripts/import/cpan.scm
-SCM_TESTS += tests/pypi.scm
+SCM_TESTS += \
+ tests/pypi.scm \
+ tests/cpan.scm
endif