summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-05 15:18:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-05 16:31:06 -0400
commitb1b41a23f4e48e35bafe282029190bba32cb7218 (patch)
tree8456b8560d73a7529e4ac3eaed0aa8f91d92ce78 /Makefile.am
parent6e71e719522adec83b49a1533af8b5838479c8fb (diff)
downloadguix-patches-b1b41a23f4e48e35bafe282029190bba32cb7218.tar
guix-patches-b1b41a23f4e48e35bafe282029190bba32cb7218.tar.gz
build: Do not compress the (already compressed) VM qcow2 images.
The qcow2 format supports compression, and the qcow2 type supported by 'guix system image' produces compressed qcow2 images. * Makefile.am (release): Do not re-compress the qcow2 VM images with xz. * doc/guix.texi (Running Guix in a VM): Adjust VM image URL.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c6028c586a..d06e1779ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -900,9 +900,7 @@ release: dist-with-updated-version all
echo "failed to produced Guix VM image for $$system" >&2 ; \
exit 1 ; \
fi ; \
- xz < "$$image" > "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz.tmp" ; \
- mv "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz.tmp" \
- "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz" ; \
+ cp "$$image" "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2"; \
done
@echo
@echo "Congratulations! All the release files are now in $(releasedir)."