summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2021-02-20 17:29:58 -0800
committerChris Marusich <cmmarusich@gmail.com>2021-03-23 23:19:57 -0700
commita16eb6c5f97f136b678540ba61f12b2c08e43e13 (patch)
tree8eefe4fd67d683f8d3fff336441348ef0c5c4283 /Makefile.am
parentb50f42680352213beb64c248c1af2f9dcc1612fc (diff)
downloadguix-patches-a16eb6c5f97f136b678540ba61f12b2c08e43e13.tar
guix-patches-a16eb6c5f97f136b678540ba61f12b2c08e43e13.tar.gz
Add powerpc64le-linux as a supported Guix architecture.
This makes powerpc64le-linux a supported architecture for Guix, but not for Guix System. * Makefile.am (SUPPORTED_SYSTEMS): Add an entry for powerpc64le-linux. * etc/guix-install.sh (chk_sys_arch): Same. * guix/packages.scm (%supported-systems): Same. * m4/guix.m4 (GUIX_ASSERT_SUPPORTED_SYSTEM): Same. * tests/guix-build.sh (all_systems): Same.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f40d9509be..1c2d45527c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,6 +14,7 @@
# Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
# Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
# Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+# Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
#
# This file is part of GNU Guix.
#
@@ -799,7 +800,8 @@ SOURCE_TARBALLS = \
$(foreach ext,tar.gz,$(PACKAGE_FULL_TARNAME).$(ext))
# Systems supported by Guix.
-SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux armhf-linux aarch64-linux
+SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux armhf-linux aarch64-linux \
+ powerpc64le-linux
# Guix binary tarballs.
BINARY_TARBALLS = \