summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-07-06 10:18:05 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-11 12:33:10 +0200
commit96bf434c70c4346c6402658d3ec57ef64a8e521e (patch)
tree83d783a071d823bbdf8fe07f1735fc01da482c2d /Makefile.am
parenta98712785e0b042a290420fd74e5a4a5da4fc68f (diff)
downloadguix-patches-96bf434c70c4346c6402658d3ec57ef64a8e521e.tar
guix-patches-96bf434c70c4346c6402658d3ec57ef64a8e521e.tar.gz
maint: Remove 'build-aux/git-authenticate.scm'.
* Makefile.am (channel_intro_commit, channel_intro_signer): New variables. (authenticate): Use it. (EXTRA_DIST): Remove 'build-aux/git-authenticate.scm'. * build-aux/git-authenticate.scm: Remove.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 20bfaba88b..20d43cd130 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -569,7 +569,6 @@ EXTRA_DIST += \
build-aux/check-channel-news.scm \
build-aux/compile-as-derivation.scm \
build-aux/generate-authors.scm \
- build-aux/git-authenticate.scm \
build-aux/test-driver.scm \
build-aux/update-guix-package.scm \
build-aux/update-NEWS.scm \
@@ -641,14 +640,17 @@ install-data-hook:
# Commit corresponding to the 'v1.0.0' tag.
commit_v1_0_0 = 6298c3ffd9654d3231a6f25390b056483e8f407c
+# Introduction of the 'guix' channel. Keep in sync with (guix channels)!
+channel_intro_commit = 9edb3f66fd807b096b48283debdcddccfea34bad
+channel_intro_signer = BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA
+
# Authenticate the current Git checkout by checking signatures on every commit
# starting from $(commit_v1_0_0).
authenticate: guix/openpgp.go guix/git-authenticate.go guix/git.go
$(AM_V_at)echo "Authenticating Git checkout..." ; \
- "$(top_builddir)/pre-inst-env" $(GUILE) \
- --no-auto-compile -e git-authenticate \
- "$(top_srcdir)/build-aux/git-authenticate.scm" \
- "$(commit_v1_0_0)"
+ "$(top_builddir)/pre-inst-env" guix git authenticate \
+ --cache-key=channels/guix --stats \
+ "$(channel_intro_commit)" "$(channel_intro_signer)"
# Assuming Guix is already installed and the daemon is up and running, this
# rule builds from $(srcdir), creating and building derivations.