summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-06-08 14:16:24 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-09 00:34:52 +0200
commit5d95ac9178c2b4f5510390b0c31d440efc3c203d (patch)
tree6a68c23765d0ea7501446ed2897ac7eca38b2d77 /Makefile.am
parent9084fc2e90bd9e0b8939f9661f0e03424290df30 (diff)
downloadguix-patches-5d95ac9178c2b4f5510390b0c31d440efc3c203d.tar
guix-patches-5d95ac9178c2b4f5510390b0c31d440efc3c203d.tar.gz
maint: 'make authenticate' starts from v1.0.0.
* Makefile.am (commit_v1_0_1): Remove. (commit_v1_0_0): New variable. (authenticate): Use it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 0feb75c7c1..9cf9318e8a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -633,17 +633,17 @@ $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
install-data-hook:
touch "$(DESTDIR)$(guileobjectdir)/guix/config.go"
-# Commit corresponding to the 'v1.0.1' tag.
-commit_v1_0_1 = d68de958b60426798ed62797ff7c96c327a672ac
+# Commit corresponding to the 'v1.0.0' tag.
+commit_v1_0_0 = 6298c3ffd9654d3231a6f25390b056483e8f407c
# Authenticate the current Git checkout by checking signatures on every commit
-# starting from $(commit_v1_0_1).
+# starting from $(commit_v1_0_0).
authenticate: guix/openpgp.go guix/git-authenticate.go guix/git.go
$(AM_V_at)echo "Authenticating Git checkout..." ; \
"$(top_builddir)/pre-inst-env" $(GUILE) \
--no-auto-compile -e git-authenticate \
"$(top_srcdir)/build-aux/git-authenticate.scm" \
- "$(commit_v1_0_1)"
+ "$(commit_v1_0_0)"
# Assuming Guix is already installed and the daemon is up and running, this
# rule builds from $(srcdir), creating and building derivations.