summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-30 23:10:01 +0100
committerLudovic Courtès <ludo@gnu.org>2015-10-30 23:10:01 +0100
commit4fca58a6c6f0a5c7d3ac2363557fabeb6524865d (patch)
tree54dce6cf1bccbb7409723434107d8b35520b9169 /Makefile.am
parent34760ae7031b19529aff2355cc458f61a8daa41f (diff)
downloadguix-patches-4fca58a6c6f0a5c7d3ac2363557fabeb6524865d.tar
guix-patches-4fca58a6c6f0a5c7d3ac2363557fabeb6524865d.tar.gz
build: Move 'guild compile' flags to a variable.
* Makefile.am (GUILD_COMPILE_FLAGS): New variable. (.scm.go): Use it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f90b1d15b..b2ee3245b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -337,6 +337,10 @@ AM_V_GUILEC = $(AM_V_GUILEC_$(V))
AM_V_GUILEC_ = $(AM_V_GUILEC_$(AM_DEFAULT_VERBOSITY))
AM_V_GUILEC_0 = @echo " GUILEC" $@;
+# Flags passed to 'guild compile'.
+GUILD_COMPILE_FLAGS = \
+ -Wformat -Wunbound-variable -Warity-mismatch
+
# Unset 'GUILE_LOAD_COMPILED_PATH' altogether while compiling. Otherwise, if
# $GUILE_LOAD_COMPILED_PATH contains $(moduledir), we may find .go files in
# there that are newer than the local .scm files (for instance because the
@@ -352,8 +356,7 @@ AM_V_GUILEC_0 = @echo " GUILEC" $@;
LC_ALL=C \
$(top_builddir)/pre-inst-env \
$(GUILD) compile -L "$(top_builddir)" -L "$(top_srcdir)" \
- -Wformat -Wunbound-variable -Warity-mismatch \
- --target="$(host)" \
+ $(GUILD_COMPILE_FLAGS) --target="$(host)" \
-o "$@" "$<"
SUFFIXES = .go