summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-16 15:03:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-16 15:40:31 +0100
commitfe52a215e53514d1857131e3a75104a081e415b6 (patch)
treea594f7774770c5a7074eac93b384c8bd8c73a4fa
parent77166eb758ff565837db9e9a26d34ba9aaa16281 (diff)
downloadguix-patches-fe52a215e53514d1857131e3a75104a081e415b6.tar
guix-patches-fe52a215e53514d1857131e3a75104a081e415b6.tar.gz
gnu: pigx-rnaseq: Disable memory hungry test.
* gnu/packages/bioinformatics.scm (pigx-rnaseq)[arguments]: Add phase to disable a memory hungry test.
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1b49cfdfbf..fa4a4957b7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12677,6 +12677,13 @@ once. This package provides tools to perform Drop-seq analyses.")
`(#:parallel-tests? #f ; not supported
#:phases
(modify-phases %standard-phases
+ ;; "test.sh" runs STAR, which requires excessive amounts of memory.
+ (add-after 'unpack 'disable-resource-intensive-test
+ (lambda _
+ (substitute* "Makefile.in"
+ (("(^ tests/test_trim_galore/test.sh).*" _ m) m)
+ (("^ test.sh") ""))
+ #t))
(add-after 'install 'wrap-executable
;; Make sure the executable finds all R modules.
(lambda* (#:key inputs outputs #:allow-other-keys)