summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-31 15:18:15 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:15 +0200
commitfe3ecc307f87d3f2d12dbeecbd180c68ab16d483 (patch)
treec6a88176c61b80635d5d098fbc30839abfdcf707
parent221c3563162926a44be20ba3899d4f8b7601b3c9 (diff)
downloadguix-patches-fe3ecc307f87d3f2d12dbeecbd180c68ab16d483.tar
guix-patches-fe3ecc307f87d3f2d12dbeecbd180c68ab16d483.tar.gz
gnu: ghc-uuid-types: Relax test framework dependency constraints.
* gnu/packages/haskell.scm (ghc-uuid-types)[arguments]: Remove "--allow-newer" configure flags and add a phase that removes dependency version constraints from all of the test frameworks.
-rw-r--r--gnu/packages/haskell.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fdc77c3d95..a5f1628854 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9034,8 +9034,16 @@ IPv4, IPv6 and MAC addresses.")
"1zdka5jnm1h6k36w3nr647yf3b5lqb336g3fkprhd6san9x52xlj"))))
(build-system haskell-build-system)
(arguments
- `(#:configure-flags (list "--allow-newer=QuickCheck"
- "--allow-newer=HUnit")))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'strip-test-framework-constraints
+ (lambda _
+ (substitute* "uuid-types.cabal"
+ (("HUnit >=1\\.2 && < 1\\.4") "HUnit")
+ (("QuickCheck >=2\\.4 && < 2\\.9") "QuickCheck")
+ (("tasty >= 0\\.10 && < 0\\.12") "tasty")
+ (("tasty-hunit == 0\\.9\\.\\*") "tasty-hunit")
+ (("tasty-quickcheck == 0\\.8\\.\\*") "tasty-quickcheck")))))))
(inputs `(("ghc-hashable" ,ghc-hashable)
("ghc-random" ,ghc-random)
("ghc-text" ,ghc-text)))