summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-31 13:44:41 +0200
committerKei Kebreau <kkebreau@posteo.net>2020-08-05 16:07:18 -0400
commitfc45f2fcf8c1cd19fa162d5c8fd43956f442f11d (patch)
treebf59c5329bb4328404385dc843a9f7c26e75f2e2
parent993391c0e129606050045abef4617149fd353568 (diff)
downloadguix-patches-fc45f2fcf8c1cd19fa162d5c8fd43956f442f11d.tar
guix-patches-fc45f2fcf8c1cd19fa162d5c8fd43956f442f11d.tar.gz
gnu: poetry: Fix problems with some dependencies.
* gnu/packages/python-xyz.scm (poetry) [arguments]: Modify the required versions of python-tomlkit, python-clikit and python-cleo. Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d3e916c5dd..48e612acd1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12430,7 +12430,12 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(substitute* "setup.py"
;; poetry won't update version as 21.0.0 relies on python > 3.6
(("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")
- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0"))
+ (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")
+ ;; Reported upstream:
+ ;; <https://github.com/python-poetry/poetry/issues/2752>.
+ (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")
+ (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")
+ (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))
#t)))))
(propagated-inputs
`(("python-cachecontrol" ,python-cachecontrol)