summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-15 16:08:30 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-15 16:39:58 +0100
commitfb9472a327cb2643d8097af6a0c60809b50622bb (patch)
tree3880002b47881a6d890684f42eb85f960f3708f7
parentceb3952764e49400d4419fea64a9201a32dad3de (diff)
downloadguix-patches-fb9472a327cb2643d8097af6a0c60809b50622bb.tar
guix-patches-fb9472a327cb2643d8097af6a0c60809b50622bb.tar.gz
gnu: Add lookingglass.
* gnu/packages/virtualization.scm (lookingglass): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/virtualization.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 85563dde6f..2fcd9e5a7a 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -709,3 +710,46 @@ mainly implemented in user space.")
incremental backups of running QEMU virtual machines via QMP, the QEMU
Machine Protocol.")
(license gpl3+)))
+
+(define-public lookingglass
+ (package
+ (name "lookingglass")
+ (version "a5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/gnif/LookingGlass/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0lrb821914fp27xaq0spwhbblssz55phiygvdlvcrkifa138v8pf"))))
+ (build-system gnu-build-system)
+ (inputs `(("fontconfig" ,fontconfig)
+ ("glu" ,glu)
+ ("mesa" ,mesa)
+ ("openssl" ,openssl)
+ ("sdl2" ,sdl2)
+ ("sdl2-ttf" ,sdl2-ttf)
+ ("spice-protocol" ,spice-protocol)))
+ (native-inputs `(("pkg-config", pkg-config)))
+ (arguments
+ `(#:tests? #f ;; No tests are available.
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chdir "client")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "bin/looking-glass-client"
+ (string-append (assoc-ref outputs "out")
+ "/bin"))
+ #t)))))
+ (home-page "https://looking-glass.hostfission.com")
+ (synopsis "KVM Frame Relay (KVMFR) implementation")
+ (description "Looking Glass allows the use of a KVM (Kernel-based Virtual
+Machine) configured for VGA PCI Pass-through without an attached physical
+monitor, keyboard or mouse. It displays the VM's rendered contents on your main
+monitor/GPU.")
+ (license gpl2+)))