summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-15 11:43:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-16 09:06:22 +0300
commitfb0c4d1ac2fe8b82474964662e08a82fb581fe3c (patch)
tree7903ea953916afacea6ee0eb1d7645575f4901b8
parent5f8fc5e3bd2ba6eeab3a337045e7d3be7379dd23 (diff)
downloadguix-patches-fb0c4d1ac2fe8b82474964662e08a82fb581fe3c.tar
guix-patches-fb0c4d1ac2fe8b82474964662e08a82fb581fe3c.tar.gz
gnu: poppler: Use 'modify-phases'.
* gnu/packages/pdf.scm (poppler)[arguments]: Use 'modify-phases'.
-rw-r--r--gnu/packages/pdf.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index dd6fc0076b..4757ef7534 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -95,14 +95,13 @@
;; Saves 8 MiB of .a files.
"--disable-static")
#:phases
- (alist-cons-before
- 'configure 'setenv
- (lambda _
- (setenv "CPATH"
- (string-append (assoc-ref %build-inputs "openjpeg-1")
- "/include/openjpeg-1.5"
- ":" (or (getenv "CPATH") ""))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'setenv
+ (lambda _
+ (setenv "CPATH"
+ (string-append (assoc-ref %build-inputs "openjpeg-1")
+ "/include/openjpeg-1.5"
+ ":" (or (getenv "CPATH") ""))))))))
(synopsis "PDF rendering library")
(description
"Poppler is a PDF rendering library based on the xpdf-3.0 code base.")