summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-27 14:05:10 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-02 10:38:43 +0200
commitf85ccf88efbe1250e472e95cce7130c8403d4f3c (patch)
tree3bb03998ddbc09d5b78c9eacb6148353b97a733c
parent26ecc2a780e3129aa3ebd7b130f1f8f17c57b4a4 (diff)
downloadguix-patches-f85ccf88efbe1250e472e95cce7130c8403d4f3c.tar
guix-patches-f85ccf88efbe1250e472e95cce7130c8403d4f3c.tar.gz
gnu: Add perl-czplib.
* gnu/packages/perl.scm (perl-czplib): New variable.
-rw-r--r--gnu/packages/perl.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f784798bd3..c528516c15 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1051,6 +1051,46 @@ contained in Appendix A of FIPS Publication 181, \"Standard for Automated
Password Generator\".")
(license (package-license perl))))
+(define-public perl-czplib
+ (package
+ (name "perl-czplib")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/czplib/czplib.v"
+ version ".tgz"))
+ (sha256
+ (base32
+ "12kln8l5h406r1ss6zbazgcshmys9nvabkrhvk2zwrrgl1saq1kf"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove .git directory
+ (delete-file-recursively ".git")
+ #t))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively "."
+ (string-append (assoc-ref outputs "out")
+ "/plib/perl5/site_perl/"
+ ,(package-version perl)
+ "/czplib/"))
+ #t)))))
+ (home-page "http://sourceforge.net/projects/czplib/")
+ (synopsis "Library for genomic analysis")
+ (description "Chaolin Zhang's Perl Library (czplib) contains assorted
+functions and data structures for processing and analysing genomic and
+bioinformatics data.")
+ (license gpl3+)))
+
(define-public perl-data-dump
(package
(name "perl-data-dump")