summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-02 10:22:20 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-02 15:01:34 -0500
commitf84f676404d90b3e8df1e1c79d186eaf1ca9b88a (patch)
treeb8ec69e0f14c2c13bf5edba82ea5d2379c25dc27
parent7efcf36e3b753a1dba6f8208f3c22d151007eaf0 (diff)
downloadguix-patches-f84f676404d90b3e8df1e1c79d186eaf1ca9b88a.tar
guix-patches-f84f676404d90b3e8df1e1c79d186eaf1ca9b88a.tar.gz
gnu: Add python-docx.
* gnu/packages/python-xyz.scm (python-docx): New variable.
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3bdd1e00d6..9526447a2a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -52,7 +52,7 @@
;;; Copyright © 2018-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018, 2019, 2021 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2018, 2019, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2019, 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Luther Thompson <lutheroto@gmail.com>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2015, 2018 Pjotr Prins <pjotr.guix@thebird.nl>
@@ -4885,6 +4885,31 @@ via commands such as @command{rst2man}, as well as supporting Python code.")
;; tests contain Python 2 syntax.
(arguments '(#:tests? #false))))
+(define-public python-docx
+ (package
+ (name "python-docx")
+ (version "0.8.11")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-docx" version))
+ (sha256
+ (base32
+ "1i7bxghb7knlyjain101qg1jmmz2b6qj03bi3vfxhvcml0rx418i"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list behave
+ python-flake8
+ python-mock
+ python-pyparsing
+ python-pytest))
+ (propagated-inputs
+ (list python-lxml))
+ (home-page "https://github.com/python-openxml/python-docx/")
+ (synopsis "Python library to create and modify Microsoft Word documents")
+ (description "This Python library can be used to create and update
+Microsoft Word (.docx) documents.")
+ (license license:expat)))
+
(define-public python-restructuredtext-lint
(package
(name "python-restructuredtext-lint")