summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-09-21 22:45:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-26 07:47:55 +0200
commitf3cfe4515ad747fe64999b9904d9866ef0921081 (patch)
treec9bc03be7bf5224ae058194f49999db444a7643b
parent684f29bd2e7ae7d51be4b873a01bf0836c3fa64b (diff)
downloadguix-patches-f3cfe4515ad747fe64999b9904d9866ef0921081.tar
guix-patches-f3cfe4515ad747fe64999b9904d9866ef0921081.tar.gz
gnu: Add r-txdb-hsapiens-ucsc-hg19-knowngene.
* gnu/packages/bioinformatics.scm (r-txdb-hsapiens-ucsc-hg19-knowngene): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3837879626..fbff139c9a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5422,6 +5422,38 @@ annotation infrastructure.")
"This package provides a pipeline for the analysis of GRO-seq data.")
(license license:gpl3+)))
+(define-public r-txdb-hsapiens-ucsc-hg19-knowngene
+ (package
+ (name "r-txdb-hsapiens-ucsc-hg19-knowngene")
+ (version "3.2.2")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "http://bioconductor.org/packages/"
+ "release/data/annotation/src/contrib"
+ "/TxDb.Hsapiens.UCSC.hg19.knownGene_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1sajhcqqwazgz2lqbik7rd935i7kpnh08zxbp2ra10j72yqy4g86"))))
+ (properties
+ `((upstream-name . "TxDb.Hsapiens.UCSC.hg19.knownGene")))
+ (build-system r-build-system)
+ ;; As this package provides little more than a very large data file it
+ ;; doesn't make sense to build substitutes.
+ (arguments `(#:substitutable? #f))
+ (propagated-inputs
+ `(("r-genomicfeatures" ,r-genomicfeatures)))
+ (home-page
+ "http://bioconductor.org/packages/TxDb.Hsapiens.UCSC.hg19.knownGene/")
+ (synopsis "Annotation package for human genome in TxDb format")
+ (description
+ "This package provides an annotation database of Homo sapiens genome
+data. It is derived from the UCSC hg19 genome and based on the \"knownGene\"
+track. The database is exposed as a @code{TxDb} object.")
+ (license license:artistic2.0)))
+
(define-public vsearch
(package
(name "vsearch")