summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 09:48:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:31:01 +0300
commitf38fb019ed9e385ec3270e6394c7a3227aa8f4bb (patch)
tree6494c5ef63bacb8a014f804fe0f5f7a301d2890a
parent5fafb361c94f3029820314457a7134a429df8404 (diff)
downloadguix-patches-f38fb019ed9e385ec3270e6394c7a3227aa8f4bb.tar
guix-patches-f38fb019ed9e385ec3270e6394c7a3227aa8f4bb.tar.gz
gnu: Add rust-log-0.4.
* gnu/packages/rust-cbindgen.scm (rust-log-0.4): New hidden variable.
-rw-r--r--gnu/packages/rust-cbindgen.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index e02a023eb1..42f3a7470b 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -239,3 +239,23 @@ the platform that libc is compiled for.")
(properties '((hidden? . #t)))
(license (list license:expat
license:asl2.0))))
+
+(define rust-log-0.4
+ (package
+ (name "rust-log")
+ (version "0.4.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "log" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1xz18ixccl5c6np4linv3ypc7hpmmgpc5zzd2ymp2ssfx0mhbdhl"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/rust-lang/log")
+ (synopsis "Lightweight logging facade for Rust")
+ (description
+ "This package provides a lightweight logging facade for Rust.")
+ (properties '((hidden? . #t)))
+ (license (list license:expat license:asl2.0))))