summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-02 17:06:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-02 17:06:58 +0100
commitf21c711a0f7f008bf9e271e2f74ad78fcdf5f24c (patch)
tree9a0e387090bcf5c630b34e9905976a6115eab4d7
parentcc39e9dbdcfb2c57f3f7aa7e9d2fb92dbc2ad742 (diff)
downloadguix-patches-f21c711a0f7f008bf9e271e2f74ad78fcdf5f24c.tar
guix-patches-f21c711a0f7f008bf9e271e2f74ad78fcdf5f24c.tar.gz
gnu: kallisto: Update to 0.46.2.
* gnu/packages/bioinformatics.scm (kallisto): Update to 0.46.2. [source]: Remove bundled htslib sources.
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d6dd6f8987..156beafc64 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11592,7 +11592,7 @@ using nucleotide or amino-acid sequence data.")
(define-public kallisto
(package
(name "kallisto")
- (version "0.44.0")
+ (version "0.46.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -11601,7 +11601,10 @@ using nucleotide or amino-acid sequence data.")
(file-name (git-file-name name version))
(sha256
(base32
- "0nj382jiywqnpgvyhichajpkkh5r0bapn43f4dx40zdaq5v4m40m"))))
+ "0ij5n7v3m90jdfi7sn8nvglfyf58abp1f5xq42r4k73l0lfds6xi"))
+ (modules '((guix build utils)))
+ (snippet
+ '(delete-file-recursively "ext/htslib/"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no "check" target