summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-05 10:00:30 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-07 18:16:59 +0200
commitf1b0d0d76f196f3c9df1ecb0587f9f833bb37d82 (patch)
tree24dc05b0668dda4c6c6c636837d23318bca4e01f
parentd1b1e21ded25425c4c706943ce1eb7356c9e305a (diff)
downloadguix-patches-f1b0d0d76f196f3c9df1ecb0587f9f833bb37d82.tar
guix-patches-f1b0d0d76f196f3c9df1ecb0587f9f833bb37d82.tar.gz
gnu: Add mbelib.
* gnu/packages/audio.scm (mbelib): New variable.
-rw-r--r--gnu/packages/audio.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index da67f78fd0..d8e4be37fa 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -29,7 +29,7 @@
;;; Copyright © 2019 Hartmt Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
@@ -5036,6 +5036,31 @@ digital radio.")
(home-page "https://www.rowetel.com/?page_id=452")
(license license:lgpl2.1)))
+(define-public mbelib
+ ;; No release since 2016, use commit directly.
+ (let ((commit "9a04ed5c78176a9965f3d43f7aa1b1f5330e771f")
+ (revision "1"))
+ (package
+ (name "mbelib")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/szechyjs/mbelib")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a7xmf87xnjzm5b437j2vnwv39x0ascja1j04c5wj6xs1529gw8h"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/szechyjs/mbelib")
+ (synopsis "P25 Phase 1 and ProVoice vocoder")
+ (description
+ "The mbelib library provides support for the 7200x4400 bit/s codec used
+in P25 Phase 1, the 7100x4400 bit/s codec used in ProVoice and the @emph{Half
+Rate} 3600x2250 bit/s vocoder used in various radio systems.")
+ (license license:bsd-0))))
+
(define-public ableton-link
(package
(name "ableton-link")