summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 23:03:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:54 +0100
commiteff3e8a471e4ca7a449f6acd338a4db0c4c95a0e (patch)
treef350d90e643aad63c21acc4a37467c23352d7cac
parent217cd2e3ee6b04ed2ac0ab4548106f8708367aa5 (diff)
downloadguix-patches-eff3e8a471e4ca7a449f6acd338a4db0c4c95a0e.tar
guix-patches-eff3e8a471e4ca7a449f6acd338a4db0c4c95a0e.tar.gz
gnu: Add r-acnr.
* gnu/packages/cran.scm (r-acnr): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ec001ab383..207bb13bcd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17326,3 +17326,24 @@ changes in code. This package is ideal for large-scale batch processing,
because it will never leave open graphics devices or incomplete image files
behind, even on errors or user interrupts.")
(license license:lgpl2.1+)))
+
+(define-public r-acnr
+ (package
+ (name "r-acnr")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "acnr" version))
+ (sha256
+ (base32
+ "087hq4i7jp67ba2finzsqjfnqbiprl33na6ryjv9zqzsdawj9cym"))))
+ (properties `((upstream-name . "acnr")))
+ (build-system r-build-system)
+ (home-page "https://github.com/mpierrejean/acnr")
+ (synopsis "Annotated copy-number regions")
+ (description
+ "This package provides SNP array data from different types of copy-number
+regions. These regions were identified manually by the authors of the package
+and may be used to generate realistic data sets with known truth.")
+ (license license:lgpl2.1+)))