summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Rodriguez <yewscion@gmail.com>2022-08-10 13:27:58 -0400
committerLudovic Courtès <ludo@gnu.org>2022-09-01 00:57:09 +0200
commitee5a85166cd4bb2099985592e3c207959013a1e8 (patch)
tree228494f9e547ab0bdc03d9e6e592fe62bc249893
parent7bae4f16503d2a901873cd0722c6675b6bb96595 (diff)
downloadguix-patches-ee5a85166cd4bb2099985592e3c207959013a1e8.tar
guix-patches-ee5a85166cd4bb2099985592e3c207959013a1e8.tar.gz
gnu: Add cbqn-bootstrap.
* gnu/packages/bqn.scm: Add cbqn-bootstrap package. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/bqn.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index 8aef8c6bcd..34bc889b74 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -123,3 +123,44 @@ the same author.")
(file-name (git-file-name "bqn-sources" commit))
(sha256
(base32 "0r6pa9lscl2395g4xlvmg90vpdsjzhin4f1r0s7brymmpvmns2yc")))))
+
+(define cbqn-bootstrap
+ (let* ((revision "1")
+ (commit "9c1cbdc99863b1da0116df61cd832137b196dc5c"))
+ (package
+ (name "cbqn-bootstrap")
+ (version (git-version "0" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dzaima/CBQN")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0w38fhwf20drkyijy6nfnhmc5g5gw0zmzgmy1q605x57znlj85a2"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;skipping tests for bootstrap
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'generate-bytecode
+ (lambda* (#:key inputs #:allow-other-keys)
+ (system (string-append #+dbqn
+ "/bin/dbqn ./genRuntime "
+ #+bqn-sources))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append #$output "/bin"))
+ (chmod "BQN" #o755)
+ (copy-recursively "BQN"
+ (string-append #$output
+ "/bin/bqn")))))))
+ (native-inputs (list dbqn clang-toolchain bqn-sources))
+ (inputs (list icedtea-8 libffi))
+ (synopsis "BQN implementation in C")
+ (description "This package provides the reference implementation of
+@uref{https://mlochbaum.github.io/BQN/, BQN}, a programming language inspired
+by APL.")
+ (home-page "https://mlochbaum.github.io/BQN/")
+ (license license:gpl3))))