summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 11:42:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 11:44:33 +0200
commitec997158dbf10b2c3408ef5e48d650c0f6c85b21 (patch)
treebab778ba4ea97ef8f3b6a9cbb8b9976200c536c5
parent62381dce865240b70c08e96f514009a8d62a338c (diff)
downloadguix-patches-ec997158dbf10b2c3408ef5e48d650c0f6c85b21.tar
guix-patches-ec997158dbf10b2c3408ef5e48d650c0f6c85b21.tar.gz
gnu: Add r-rslurm.
* gnu/packages/cran.scm (r-rslurm): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e05568741..b12e8b30e8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11745,6 +11745,29 @@ builders who wish to wrap command line software, and to help analysts stay
inside R when they might usually leave to execute non-R software.")
(license license:expat)))
+(define-public r-rslurm
+ (package
+ (name "r-rslurm")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rslurm" version))
+ (sha256
+ (base32
+ "0fn2na8prsaxa03x5wi3105gpsxc35qvgmik7wy3nylvx4wdfv9g"))))
+ (properties `((upstream-name . "rslurm")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-whisker" ,r-whisker)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "http://cyberhelp.sesync.org/rslurm/")
+ (synopsis "Submit R calculations to a Slurm cluster")
+ (description
+ "This package provides functions that simplify submitting R scripts to a
+Slurm workload manager, in part by automating the division of embarrassingly
+parallel calculations across cluster nodes.")
+ (license license:gpl3)))
+
(define-public r-weights
(package
(name "r-weights")