summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 20:36:17 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:14 +0200
commite59983ece567b9131b45113777a317394ed68e25 (patch)
treef0a382be92ecdea3412a5f5515fad50eda981428
parente0b8cc34a483beb19a6651a3fac8ad2eeb89cd46 (diff)
downloadguix-patches-e59983ece567b9131b45113777a317394ed68e25.tar
guix-patches-e59983ece567b9131b45113777a317394ed68e25.tar.gz
gnu: ghc-hinotify: Update to 0.3.10.
* gnu/packages/haskell.scm (ghc-hinotify): Update to 0.3.10. [inputs]: Add ghc-async.
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4cec8d0ba7..6e9185cb3f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7921,7 +7921,7 @@ helper functions for Lists, Maybes, Tuples, Functions.")
(define-public ghc-hinotify
(package
(name "ghc-hinotify")
- (version "0.3.8.1")
+ (version "0.3.10")
(source (origin
(method url-fetch)
(uri (string-append
@@ -7929,8 +7929,10 @@ helper functions for Lists, Maybes, Tuples, Functions.")
"hinotify-" version ".tar.gz"))
(sha256
(base32
- "03c1f4d7x805zdiq2w26kl09xrfjw19saycdkhnixzv2qcr6xm1p"))))
+ "17ax3n68a5c2ddazp86aciliskrh6znd3bnry0wcllmb6dbpsaxg"))))
(build-system haskell-build-system)
+ (inputs
+ `(("ghc-async" ,ghc-async)))
(home-page "https://github.com/kolmodin/hinotify.git")
(synopsis "Haskell binding to inotify")
(description "This library provides a wrapper to the Linux kernel's inotify