summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-06-25 08:39:02 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-06-27 06:27:53 -0400
commite55354b87eae085105b1d89eebcab0755e81d4c9 (patch)
treeb510494073cd46b1c2d10521e1a9001486235e66
parentdc55b8b2341483a8b5d14a4335a609cc92eaceb2 (diff)
downloadguix-patches-e55354b87eae085105b1d89eebcab0755e81d4c9.tar
guix-patches-e55354b87eae085105b1d89eebcab0755e81d4c9.tar.gz
gnu: Consolidate libjpeg, libpng, and libtiff into one module.
* gnu/packages/image.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add image.scm and remove libjpeg.scm, libpng.scm, and libtiff.scm. * gnu/packages/libjpeg.scm, gnu/packages/libpng.scm, gnu/packages/libtiff.scm: Delete files. * gnu/packages/emacs.scm gnu/packages/games.scm, gnu/packages/gd.scm, gnu/packages/geeqie.scm, gnu/packages/ghostscript.scm, gnu/packages/gimp.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnustep.scm, gnu/packages/gnuzilla.scm, gnu/packages/graphviz.scm, gnu/packages/gtk.scm, gnu/packages/imagemagick.scm, gnu/packages/inkscape.scm, gnu/packages/netpbm.scm, gnu/packages/pdf.scm, gnu/packages/plotutils.scm, gnu/packages/qemu.scm, gnu/packages/qt.scm, gnu/packages/scheme.scm, gnu/packages/sdl.scm, gnu/packages/slim.scm, gnu/packages/tcl.scm, gnu/packages/texlive.scm, gnu/packages/video.scm, gnu/packages/xiph.scm, gnu/packages/xorg.scm: Use (gnu packages image) module.
-rw-r--r--gnu-system.am4
-rw-r--r--gnu/packages/emacs.scm4
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/gd.scm3
-rw-r--r--gnu/packages/geeqie.scm2
-rw-r--r--gnu/packages/ghostscript.scm4
-rw-r--r--gnu/packages/gimp.scm3
-rw-r--r--gnu/packages/gnome.scm3
-rw-r--r--gnu/packages/gnunet.scm3
-rw-r--r--gnu/packages/gnustep.scm2
-rw-r--r--gnu/packages/gnuzilla.scm3
-rw-r--r--gnu/packages/graphviz.scm3
-rw-r--r--gnu/packages/gtk.scm4
-rw-r--r--gnu/packages/image.scm122
-rw-r--r--gnu/packages/imagemagick.scm4
-rw-r--r--gnu/packages/inkscape.scm2
-rw-r--r--gnu/packages/libjpeg.scm56
-rw-r--r--gnu/packages/libpng.scm52
-rw-r--r--gnu/packages/libtiff.scm65
-rw-r--r--gnu/packages/netpbm.scm4
-rw-r--r--gnu/packages/pdf.scm4
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/qemu.scm3
-rw-r--r--gnu/packages/qt.scm3
-rw-r--r--gnu/packages/scheme.scm2
-rw-r--r--gnu/packages/sdl.scm4
-rw-r--r--gnu/packages/slim.scm3
-rw-r--r--gnu/packages/tcl.scm3
-rw-r--r--gnu/packages/texlive.scm2
-rw-r--r--gnu/packages/video.scm3
-rw-r--r--gnu/packages/xiph.scm2
-rw-r--r--gnu/packages/xorg.scm2
32 files changed, 150 insertions, 228 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 908c922d25..ec697c556a 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -121,6 +121,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/hurd.scm \
gnu/packages/icu4c.scm \
gnu/packages/idutils.scm \
+ gnu/packages/image.scm \
gnu/packages/imagemagick.scm \
gnu/packages/indent.scm \
gnu/packages/inkscape.scm \
@@ -135,11 +136,8 @@ GNU_SYSTEM_MODULES = \
gnu/packages/libevent.scm \
gnu/packages/libffi.scm \
gnu/packages/libidn.scm \
- gnu/packages/libjpeg.scm \
gnu/packages/libphidget.scm \
- gnu/packages/libpng.scm \
gnu/packages/libsigsegv.scm \
- gnu/packages/libtiff.scm \
gnu/packages/libunistring.scm \
gnu/packages/libusb.scm \
gnu/packages/libunwind.scm \
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 87c4e894c5..af8772eefd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -30,9 +30,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages xorg)
#:use-module (gnu packages lesstif)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libtiff)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages giflib)
#:use-module (gnu packages linux)
#:use-module ((gnu packages compression)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ce75e6d17c..22412e4093 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -31,7 +31,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages libcanberra)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages python)
#:use-module (gnu packages readline)
#:use-module (gnu packages xorg)
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index ce3db6709c..caeaeae36b 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -21,8 +21,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module (gnu packages)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages compression)
#:use-module ((guix licenses) #:select (bsd-style)))
diff --git a/gnu/packages/geeqie.scm b/gnu/packages/geeqie.scm
index 2927f2d5f9..7d8bb67556 100644
--- a/gnu/packages/geeqie.scm
+++ b/gnu/packages/geeqie.scm
@@ -25,7 +25,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module ((gnu packages ghostscript)
#:select (lcms))
#:use-module (gnu packages compression)
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 7bdd63e55c..13997cd4e6 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -20,9 +20,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libtiff)
+ #:use-module (gnu packages image)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index bdcd46f38e..33c3887894 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -26,8 +26,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module ((gnu packages ghostscript)
#:select (lcms))
#:use-module (gnu packages compression)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b10f2a6646..ee7c7c5ab1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -35,8 +35,7 @@
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages iso-codes)
#:use-module (gnu packages libcanberra)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 804c9f4de5..b047032710 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -30,8 +30,7 @@
#:use-module (gnu packages groff)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages libidn)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libtiff)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libunistring)
#:use-module (gnu packages maths)
#:use-module (gnu packages openssl)
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 8584ba6096..ea398bbc34 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -23,7 +23,7 @@
#:use-module (guix licenses)
#:use-module (gnu packages xorg)
#:use-module (gnu packages fontutils)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pkg-config))
(define-public windowmaker
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 251520952b..14f75bff45 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -32,8 +32,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages compression)
#:use-module (gnu packages libevent)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libffi)
#:use-module (gnu packages python)
#:use-module (gnu packages xorg)
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index eb54b5dc29..dc477f30b3 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -25,8 +25,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages glib)
#:use-module (gnu packages bison)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module (gnu packages autotools)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages fontutils)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 54cfbfb5f1..2823ef008f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -29,9 +29,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages icu4c)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libtiff)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
new file mode 100644
index 0000000000..014266cbb0
--- /dev/null
+++ b/gnu/packages/image.scm
@@ -0,0 +1,122 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages image)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages file)
+ #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public libpng
+ (package
+ (name "libpng")
+ (version "1.5.17")
+ (source (origin
+ (method url-fetch)
+
+ ;; Note: upstream removes older tarballs.
+ (uri (list (string-append "mirror://sourceforge/libpng/libpng15/"
+ version "/libpng-" version ".tar.xz")
+ (string-append
+ "ftp://ftp.simplesystems.org/pub/libpng/png/src"
+ "/libpng15/libpng-" version ".tar.xz")))
+ (sha256
+ (base32 "19wj293r4plbfgb43yhrc2qx8bsch9gbazazfqrj9haa7lsk29jp"))))
+ (build-system gnu-build-system)
+
+ ;; libpng.la says "-lz", so propagate it.
+ (propagated-inputs `(("zlib" ,zlib)))
+
+ (synopsis "Library for handling PNG files")
+ (description
+ "Libpng is the official PNG (Portable Network Graphics) reference
+library. It supports almost all PNG features and is extensible.")
+ (license license:zlib)
+ (home-page "http://www.libpng.org/pub/png/libpng.html")))
+
+(define-public libjpeg
+ (package
+ (name "libjpeg")
+ (version "9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0dg5wxcx3cw0hal9gvivj97vid9z0s5sb1yvg55hpxmafn9rxqn4"))))
+ (build-system gnu-build-system)
+ (synopsis "Libjpeg, a library for handling JPEG files")
+ (description
+ "Libjpeg implements JPEG image encoding, decoding, and transcoding.
+JPEG is a standardized compression method for full-color and gray-scale
+images.
+The included programs provide conversion between the JPEG format and
+image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
+ (license license:ijg)
+ (home-page "http://www.ijg.org/")))
+
+(define-public libjpeg-8
+ (package (inherit libjpeg)
+ (version "8d")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
+ version ".tar.gz"))
+ (sha256 (base32
+ "1cz0dy05mgxqdgjf52p54yxpyy95rgl30cnazdrfmw7hfca9n0h0"))))))
+
+(define-public libtiff
+ (package
+ (name "libtiff")
+ (version "4.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.remotesensing.org/pub/libtiff/tiff-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0wj8d1iwk9vnpax2h29xqc2hwknxg3s0ay2d5pxkg59ihbifn6pa"))))
+ (build-system gnu-build-system)
+ (inputs `(("zlib" ,zlib)
+ ("libjpeg-8" ,libjpeg-8)))
+ ;; currently does not compile with libjpeg version 9
+ (native-inputs `(("file" ,file)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-jpeg-include-dir="
+ (assoc-ref %build-inputs "libjpeg-8")
+ "/include"))
+ #:phases
+ (alist-cons-before
+ 'configure 'patch-configure
+ (lambda _
+ (substitute* "configure"
+ (("`/usr/bin/file")
+ (string-append "`" (which "file")))))
+ %standard-phases)))
+ (synopsis "Libtiff, a library for handling TIFF files")
+ (description
+ "Libtiff provides support for the Tag Image File Format (TIFF), a format
+used for storing image data.
+Included are a library, libtiff, for reading and writing TIFF and a small
+collection of tools for doing simple manipulations of TIFF images.")
+ (license (license:bsd-style "file://COPYRIGHT"
+ "See COPYRIGHT in the distribution."))
+ (home-page "http://www.libtiff.org/")))
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 0c80c0a57f..e557893faf 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -27,9 +27,7 @@
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libtiff)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 845853f665..9c3c9c2f74 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -36,7 +36,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages fontutils)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pkg-config))
(define-public inkscape
diff --git a/gnu/packages/libjpeg.scm b/gnu/packages/libjpeg.scm
deleted file mode 100644
index 6415210097..0000000000
--- a/gnu/packages/libjpeg.scm
+++ /dev/null
@@ -1,56 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages libjpeg)
- #:use-module (gnu packages)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public libjpeg
- (package
- (name "libjpeg")
- (version "9")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
- version ".tar.gz"))
- (sha256 (base32
- "0dg5wxcx3cw0hal9gvivj97vid9z0s5sb1yvg55hpxmafn9rxqn4"))))
- (build-system gnu-build-system)
- (synopsis "Libjpeg, a library for handling JPEG files")
- (description
- "Libjpeg implements JPEG image encoding, decoding, and transcoding.
-JPEG is a standardized compression method for full-color and gray-scale
-images.
-The included programs provide conversion between the JPEG format and
-image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
- (license ijg)
- (home-page "http://www.ijg.org/")))
-
-(define-public libjpeg-8
- (package (inherit libjpeg)
- (version "8d")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
- version ".tar.gz"))
- (sha256 (base32
- "1cz0dy05mgxqdgjf52p54yxpyy95rgl30cnazdrfmw7hfca9n0h0"))))))
-
diff --git a/gnu/packages/libpng.scm b/gnu/packages/libpng.scm
deleted file mode 100644
index 810645ea68..0000000000
--- a/gnu/packages/libpng.scm
+++ /dev/null
@@ -1,52 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages libpng)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public libpng
- (package
- (name "libpng")
- (version "1.5.17")
- (source (origin
- (method url-fetch)
-
- ;; Note: upstream removes older tarballs.
- (uri (list (string-append "mirror://sourceforge/libpng/libpng15/"
- version "/libpng-" version ".tar.xz")
- (string-append
- "ftp://ftp.simplesystems.org/pub/libpng/png/src"
- "/libpng15/libpng-" version ".tar.xz")))
- (sha256
- (base32 "19wj293r4plbfgb43yhrc2qx8bsch9gbazazfqrj9haa7lsk29jp"))))
- (build-system gnu-build-system)
-
- ;; libpng.la says "-lz", so propagate it.
- (propagated-inputs `(("zlib" ,zlib)))
-
- (synopsis "Library for handling PNG files")
- (description
- "Libpng is the official PNG (Portable Network Graphics) reference
-library. It supports almost all PNG features and is extensible.")
- (license license:zlib)
- (home-page "http://www.libpng.org/pub/png/libpng.html")))
diff --git a/gnu/packages/libtiff.scm b/gnu/packages/libtiff.scm
deleted file mode 100644
index f4b72c80bc..0000000000
--- a/gnu/packages/libtiff.scm
+++ /dev/null
@@ -1,65 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages libtiff)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages file)
- #:use-module (gnu packages libjpeg)
- #:use-module ((guix licenses) #:select (bsd-style))
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public libtiff
- (package
- (name "libtiff")
- (version "4.0.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://ftp.remotesensing.org/pub/libtiff/tiff-"
- version ".tar.gz"))
- (sha256 (base32
- "0wj8d1iwk9vnpax2h29xqc2hwknxg3s0ay2d5pxkg59ihbifn6pa"))))
- (build-system gnu-build-system)
- (inputs `(("zlib" ,zlib)
- ("libjpeg-8" ,libjpeg-8)))
- ;; currently does not compile with libjpeg version 9
- (native-inputs `(("file" ,file)))
- (arguments
- `(#:configure-flags
- (list (string-append "--with-jpeg-include-dir="
- (assoc-ref %build-inputs "libjpeg-8")
- "/include"))
- #:phases
- (alist-cons-before
- 'configure 'patch-configure
- (lambda _
- (substitute* "configure"
- (("`/usr/bin/file")
- (string-append "`" (which "file")))))
- %standard-phases)))
- (synopsis "Libtiff, a library for handling TIFF files")
- (description
- "Libtiff provides support for the Tag Image File Format (TIFF), a format
-used for storing image data.
-Included are a library, libtiff, for reading and writing TIFF and a small
-collection of tools for doing simple manipulations of TIFF images.")
- (license (bsd-style "file://COPYRIGHT"
- "See COPYRIGHT in the distribution."))
- (home-page "http://www.libtiff.org/")))
diff --git a/gnu/packages/netpbm.scm b/gnu/packages/netpbm.scm
index 64db777c71..21bef5fd88 100644
--- a/gnu/packages/netpbm.scm
+++ b/gnu/packages/netpbm.scm
@@ -21,9 +21,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages ghostscript)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libtiff)
+ #:use-module (gnu packages image)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index dd0759dbe7..c8fa4593fb 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -27,9 +27,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages lesstif)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libtiff)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xorg)
#:use-module (gnu packages glib)
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 7ec79a7ef5..23b3183e82 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -22,7 +22,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages))
(define-public plotutils
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index f3c2ed9d2b..e396127fe3 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -30,8 +30,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages compression)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module (gnu packages attr)
#:use-module (gnu packages linux)
#:use-module (gnu packages xorg)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index de8dbdea48..4d367d8ab7 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -28,8 +28,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages glib)
#:use-module (gnu packages icu4c)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages mysql)
#:use-module (gnu packages openssl)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index df4bf7f438..98a28e79a0 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -34,7 +34,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libffi)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module (ice-9 match))
(define-public mit-scheme
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index bbf8597c7a..110cf52e1d 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -23,9 +23,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module ((gnu packages fontutils) #:prefix font:)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libtiff)
+ #:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages mp3)
#:use-module (gnu packages pkg-config)
diff --git a/gnu/packages/slim.scm b/gnu/packages/slim.scm
index cea3748985..b179acfc56 100644
--- a/gnu/packages/slim.scm
+++ b/gnu/packages/slim.scm
@@ -28,8 +28,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages gl)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages linux))
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 4859c2be72..6dfd3b23b9 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -24,8 +24,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (gnu packages)
- #:use-module (gnu packages libpng)
- #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages image)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xorg)
diff --git a/gnu/packages/texlive.scm b/gnu/packages/texlive.scm
index fc65a4bb33..f562732318 100644
--- a/gnu/packages/texlive.scm
+++ b/gnu/packages/texlive.scm
@@ -29,7 +29,7 @@
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4509d81528..ab75e44291 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -32,8 +32,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gnutls)
- #:use-module (gnu packages libjpeg)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages mp3)
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 66c6c1373d..03cf0e49d2 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -26,7 +26,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages doxygen)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages linux)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index a480896083..ce07d77299 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -35,7 +35,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
- #:use-module (gnu packages libpng)
+ #:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages m4)
#:use-module (gnu packages perl)