summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 09:43:49 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:53:03 +0100
commite4150032027455ccf920e2f407754e93ca052dec (patch)
treee0d028c016fe55de17e15106094bd4955771fc1e
parent804fad34e8e0f74483e987cfe5f6a496c1debe74 (diff)
downloadguix-patches-e4150032027455ccf920e2f407754e93ca052dec.tar
guix-patches-e4150032027455ccf920e2f407754e93ca052dec.tar.gz
gnu: Add r-striprtf.
* gnu/packages/cran.scm (r-striprtf): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7f6003ac01..0ffc90488a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27545,3 +27545,26 @@ extracting them into new variables. For example, emoticons are often used in
text but not always easily handled by analysis algorithms. The
@code{replace_emoticon()} function replaces emoticons with word equivalents.")
(license license:gpl2)))
+
+(define-public r-striprtf
+ (package
+ (name "r-striprtf")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "striprtf" version))
+ (sha256
+ (base32
+ "1ra6aalalig6drsj26z9s24lmb10zssagqrvgqqi4358zbm8gwcd"))))
+ (properties `((upstream-name . "striprtf")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-magrittr" ,r-magrittr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-stringr" ,r-stringr)))
+ (home-page "https://github.com/kota7/striprtf")
+ (synopsis "Extract Text from RTF File")
+ (description
+ "Extracts plain text from @dfn{Rich Text Format} (RTF) file.")
+ (license license:expat)))