summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-22 11:49:00 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-22 23:56:04 -0500
commite0e23164202ad9328ffeadde5e900857cb008124 (patch)
tree97758de30466d4af7c5ac2ac015a210329626f57
parent12f68319e8d341b10ba88a11a4e61a0d44e175e6 (diff)
downloadguix-patches-e0e23164202ad9328ffeadde5e900857cb008124.tar
guix-patches-e0e23164202ad9328ffeadde5e900857cb008124.tar.gz
gnu: libgit2: Update to 1.3.0.
* gnu/packages/patches/libgit2-mtime-0.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. * gnu/packages/version-control.scm (libgit2): Update to 1.3.0. [source]: Remove patch and simplify snippet. [phases]: Remove trailing #t.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/libgit2-mtime-0.patch14
-rw-r--r--gnu/packages/version-control.scm24
3 files changed, 12 insertions, 27 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 01a80cbdfd..854b1b5d04 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1347,7 +1347,6 @@ dist_patch_DATA = \
%D%/packages/patches/libcyaml-libyaml-compat.patch \
%D%/packages/patches/libexpected-nofetch.patch \
%D%/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch \
- %D%/packages/patches/libgit2-mtime-0.patch \
%D%/packages/patches/libgnome-encoding.patch \
%D%/packages/patches/libgnomeui-utf8.patch \
%D%/packages/patches/libgrss-CVE-2016-2001.patch \
diff --git a/gnu/packages/patches/libgit2-mtime-0.patch b/gnu/packages/patches/libgit2-mtime-0.patch
deleted file mode 100644
index a6fdb50fff..0000000000
--- a/gnu/packages/patches/libgit2-mtime-0.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-The Clar test framework has a bug whereby it skips the parsing phase
-on files with mtime=0.
-
-Reported upstream at <https://github.com/vmg/clar/pull/78>.
-
-diff --git a/tests/generate.py b/tests/generate.py
-index b639c8f..111ca41 100644
---- a/tests/generate.py
-+++ b/tests/generate.py
-@@ -63,3 +63,3 @@ class Module(object):
-
-- self.mtime = 0
-+ self.mtime = None # Guix sets all file mtimes to '0'
- self.enabled = True
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b8f99f1885..9d1c84b563 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -786,19 +786,20 @@ to GitHub contributions calendar.")
(define-public libgit2
(package
(name "libgit2")
- (version "1.1.0")
+ (version "1.3.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/libgit2/libgit2/"
- "releases/download/v" version
- "/libgit2-" version ".tar.gz"))
+ ;; Since v1.1.1, release artifacts are no longer offered (see:
+ ;; https://github.com/libgit2/libgit2/discussions/5932#discussioncomment-1682729).
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libgit2/libgit2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1fjdglkh04qv3b4alg621pxa689i0wlf8m7nf2755zawjr2zhwxd"))
- (patches (search-patches "libgit2-mtime-0.patch"))
- (snippet '(begin
- (delete-file-recursively "deps") #t))
- (modules '((guix build utils)))))
+ "0vgpb2175a5dhqiy1iwywwppahgqhi340i8bsvafjpvkw284vazd"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "deps"))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
@@ -820,8 +821,7 @@ to GitHub contributions calendar.")
(("#!/bin/sh") (string-append "#!" (which "sh"))))
(substitute* "tests/clar/fs.h"
(("/bin/cp") (which "cp"))
- (("/bin/rm") (which "rm")))
- #t))
+ (("/bin/rm") (which "rm")))))
;; Run checks more verbosely, unless we are cross-compiling.
(replace 'check
(lambda* (#:key (tests? #t) #:allow-other-keys)