summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-20 05:22:28 +0000
committerLars-Dominik Braun <lars@6xq.net>2021-05-08 11:27:48 +0200
commite0def67669209e1bf948f79b1c46faff687baece (patch)
tree7289d5d72763eb66222732491b576ed1e37e572d
parentbd6f03846b3623f5ce9272bddad221d13093f923 (diff)
downloadguix-patches-e0def67669209e1bf948f79b1c46faff687baece.tar
guix-patches-e0def67669209e1bf948f79b1c46faff687baece.tar.gz
gnu: Add python-pyls-black.
* gnu/packages/python-xyz.scm (python-pyls-black): New variable.
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 24a49685c7..9381f50f05 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1131,6 +1131,39 @@ concepts.")
(define-public python2-h5py
(package-with-python2 python-h5py))
+(define-public python-pyls-black
+ (package
+ (name "python-pyls-black")
+ (version "0.4.6")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rupert/pyls-black/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cjf0mjn156qp0x6md6mncs31hdpzfim769c2lixaczhyzwywqnj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "pytest"))
+ (propagated-inputs
+ `(("python-black" ,python-black)
+ ("python-language-server"
+ ,python-language-server)
+ ("python-toml" ,python-toml)))
+ (native-inputs
+ `(("python-flake8" ,python-flake8)
+ ("python-isort" ,python-isort)
+ ("python-mypy" ,python-mypy)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/rupert/pyls-black")
+ (synopsis "Black plugin for the Python Language Server")
+ (description "Black plugin for the Python Language Server.")
+ (license license:expat)))
+
(define-public python-sh
(package
(name "python-sh")