summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 23:05:45 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:16 +0200
commitded4ac387173cedbaf917479bdf763cffbb22e73 (patch)
tree138afd8569aa54ef539cc77d0e57570614f99ae6
parent1aacec9e3d4294d3dadd153170878a9a4748ca24 (diff)
downloadguix-patches-ded4ac387173cedbaf917479bdf763cffbb22e73.tar
guix-patches-ded4ac387173cedbaf917479bdf763cffbb22e73.tar.gz
gnu: ghc-temporary: Update to 1.3.
* gnu/packages/haskell.scm (ghc-temporary): Update to 1.3. [inputs]: Add ghc-random. [native-inputs]: Add ghc-base-compat, ghc-tasty, and ghc-tasty-hunit.
-rw-r--r--gnu/packages/haskell.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 70847aec1f..dfe3756649 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3399,7 +3399,7 @@ for Haskell.")
(define-public ghc-temporary
(package
(name "ghc-temporary")
- (version "1.2.0.4")
+ (version "1.3")
(source
(origin
(method url-fetch)
@@ -3409,9 +3409,15 @@ for Haskell.")
".tar.gz"))
(sha256
(base32
- "0qk741yqnpd69sksgks2vb7zi50rglp9m498lzw4sh268a017rsi"))))
+ "144qhwfwg37l3k313raf4ssiz16jbgwlm1nf4flgqpsbd69jji4c"))))
(build-system haskell-build-system)
- (inputs `(("ghc-exceptions" ,ghc-exceptions)))
+ (inputs
+ `(("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-random" ,ghc-random)))
+ (native-inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
(home-page "https://www.github.com/batterseapower/temporary")
(synopsis "Temporary file and directory support")
(description "The functions for creating temporary files and directories