summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2019-07-15 11:21:24 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-20 01:32:17 +0200
commitdd3779c276931047928536c34bd0ac162762252b (patch)
tree7703d9ae0e7c2b2d7da5d696fc727fdd4952ee07
parent723bdb8ef0175716a2bfa93e96c3fd757d7b2679 (diff)
downloadguix-patches-dd3779c276931047928536c34bd0ac162762252b.tar
guix-patches-dd3779c276931047928536c34bd0ac162762252b.tar.gz
gnu: Add emacs-zerodark-theme.
* gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 110a053b29..2f04375773 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
;;; Copyright © 2019 Amar Singh <nly@disroot.org>
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autitici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16720,3 +16721,29 @@ directories, direct visualisation of image files, jumping directly to links by
name (with autocompletion), a simple bookmark management system and
connections using TLS encryption.")
(license license:gpl3+)))
+
+(define-public emacs-zerodark-theme
+ (package
+ (name "emacs-zerodark-theme")
+ (version "4.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.petton.fr/nico/zerodark-theme.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nnlxzsmhsbszqigcyxak9i1a0digrd13gv6v18ck4h760mihh1m"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-all-the-icons" ,emacs-all-the-icons)))
+ (home-page
+ "https://gitlab.petton.fr/nico/zerodark-theme")
+ (synopsis
+ "Dark, medium contrast theme for Emacs")
+ (description
+ "Zerodark is a dark theme inspired from One Dark and Niflheim.
+An optional mode-line format can be enabled with @code{zerodark-setup-modeline-format}.")
+ (license license:gpl3+)))