summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2020-12-29 13:41:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-29 14:39:55 +0100
commitdd35b58ce3baec62298e77a9484fffbbcb19b31c (patch)
treeed25214fb01417fb75ebc86f554f119a6172a66d
parentffe1f205eafdc10bfc0545a92136a265665e8ab4 (diff)
downloadguix-patches-dd35b58ce3baec62298e77a9484fffbbcb19b31c.tar
guix-patches-dd35b58ce3baec62298e77a9484fffbbcb19b31c.tar.gz
gnu: Add r-mlr3misc.
* gnu/packages/cran.scm (r-mlr3misc): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fd9668dacc..527412b365 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25435,3 +25435,28 @@ classification. Additionally, meta information about the performance measures
can be queried, e.g. what the best and worst possible performances scores
are.")
(license license:lgpl3)))
+
+(define-public r-mlr3misc
+ (package
+ (name "r-mlr3misc")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3misc" version))
+ (sha256
+ (base32
+ "1q63i2059bf7cf61kwm0dqnk5vd60i0j4flziswwdk07fjxqh8xr"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-backports" ,r-backports)
+ ("r-checkmate" ,r-checkmate)
+ ("r-data-table" ,r-data-table)
+ ("r-r6" ,r-r6)))
+ (home-page "https://mlr3misc.mlr-org.com/")
+ (synopsis "Helper functions for mlr3")
+ (description "@code{mlr3misc} provides frequently used helper functions
+and assertions used in @code{mlr3} and its companion packages. It comes with
+helper functions for functional programming, for printing, to work with
+@code{data.table}, as well as some generally useful @code{R6} classes. This
+package also supersedes the package @code{BBmisc}.")
+ (license license:lgpl3)))