summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-23 00:24:08 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-23 06:15:20 +0200
commitdc12a37a0d70bd56a5fac59af5a5196d6b525482 (patch)
tree68c7189aae43c5b35bb6b5fbd785c0d8f6da758f
parentc9f01b73cb3cfb6b82f74b621f7cff65fb52749d (diff)
downloadguix-patches-dc12a37a0d70bd56a5fac59af5a5196d6b525482.tar
guix-patches-dc12a37a0d70bd56a5fac59af5a5196d6b525482.tar.gz
gnu: net-snmp: Update to 5.9 [fixes CVE-2019-20892].
* gnu/packages/networking.scm (net-snmp): Update to 5.9. [inputs]: Add ncurses. [native-inputs]: Add pkg-config.
-rw-r--r--gnu/packages/networking.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 49e4679dcf..85c43efd50 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2945,14 +2945,14 @@ Features:
(define-public net-snmp
(package
(name "net-snmp")
- (version "5.8")
+ (version "5.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/net-snmp/net-snmp/"
version "/net-snmp-" version ".tar.gz"))
(sha256
(base32
- "1pvajzj9gmj56dmwix0ywmkmy2pglh6nny646hkm7ghfhh03bz5j"))
+ "0wb0vyafpspw3mcifkjjmf17r1r80kjvslycscb8nvaxz1k3lc04"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -2999,12 +2999,15 @@ Features:
" -NET")))
#t)))))
(inputs
- `(("perl" ,perl)
+ `(("libnl" ,libnl)
+ ("ncurses" ,ncurses) ; for the ‘apps’
("openssl" ,openssl)
- ("libnl" ,libnl)))
- ;; These inputs are only needed for tests.
+ ("perl" ,perl)))
(native-inputs
- `(("net-tools" ,net-tools)
+ `(("pkg-config" ,pkg-config)
+
+ ;; For tests only.
+ ("net-tools" ,net-tools)
("coreutils" ,coreutils)
("grep" ,grep)))
(home-page "http://www.net-snmp.org/")