summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-06 21:43:57 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-06 21:46:25 +0100
commitd9f0788ad282b93f97fe694c68f79c2cf570dcf6 (patch)
treeb06366d3684db75a2483cc6bc1195926d065a3b2
parent8c4c2a983e28d08034cb151ed9c1a41094bc921b (diff)
downloadguix-patches-d9f0788ad282b93f97fe694c68f79c2cf570dcf6.tar
guix-patches-d9f0788ad282b93f97fe694c68f79c2cf570dcf6.tar.gz
gnu: guile-next: Update to 2.1.2.
* gnu/packages/guile.scm (guile-next): Update to 2.1.2. Add 'snippet'.
-rw-r--r--gnu/packages/guile.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 861a18fce8..6cbca7a478 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
@@ -195,14 +195,21 @@ without requiring the source code to be rewritten.")
(define-public guile-next
(package (inherit guile-2.0)
(name "guile-next")
- (version "2.1.1")
+ (version "2.1.2")
(source (origin
(method url-fetch)
(uri (string-append "ftp://alpha.gnu.org/gnu/guile/guile-"
version ".tar.xz"))
(sha256
(base32
- "0nixmx7as79g8rr8bvznh59pwcc2jd22cfk17v309p57zp2c255r"))))
+ "0p971k3v04jj5klnv145g4172cpcp90arf0wvxxj2aqkg16j9m9c"))
+ (modules '((guix build utils)))
+
+ ;; Remove the pre-built object files. Instead, build everything
+ ;; from source, at the expense of significantly longer build
+ ;; times (almost 3 hours on a 4-core Intel i5).
+ (snippet '(for-each delete-file
+ (find-files "prebuilt" "\\.go$")))))
(synopsis "Snapshot of what will become version 2.2 of GNU Guile")))
(define-public guile-for-guile-emacs