summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 07:14:26 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:29 +0200
commitd6a413a7ede91e31530a1b9d645c3aa3cb8eaa26 (patch)
tree502a2407562926d5cd3d312a05af62142945e72b
parent97f3fe7c04a7c0cd9046c1351c93812e4c48cc15 (diff)
downloadguix-patches-d6a413a7ede91e31530a1b9d645c3aa3cb8eaa26.tar
guix-patches-d6a413a7ede91e31530a1b9d645c3aa3cb8eaa26.tar.gz
gnu: Add schroedinger.
* gnu/packages/video.scm (schroedinger): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/video.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 10d2ea7899..1133321ffc 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -172,6 +172,55 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public schroedinger
+ (package
+ (name "schroedinger")
+ (version "1.0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://launchpad.net/" name "/trunk/" version
+ "/+download/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "04prr667l4sn4zx256v1z36a0nnkxfdqyln48rbwlamr6l3jlmqy"))))
+ (build-system gnu-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))
+ #t))))))
+ (native-inputs
+ `(("dash" ,dash)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glew" ,glew)
+ ("opengl" ,mesa)))
+ (propagated-inputs
+ `(("orc" ,orc)))
+ (synopsis "Dirac video codec")
+ (description "Schroedinger is a project implementing the Dirac video codec in
+ANSI C code. It is meant to be highly optimized and portable. It is developed
+as a joint effort between the BBC and Fluendo.")
+ (home-page "https://launchpad.net/schroedinger")
+ (license
+ ;; This library is licensed under 4 different licenses,
+ ;; and you can choose to use it under the terms of any one of them.
+ (list
+ license:gpl2+
+ license:lgpl2.0+
+ license:expat
+ license:mpl1.1))))
+
(define-public libmms
(package
(name "libmms")