summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2020-07-30 18:12:44 -0400
committerMark H Weaver <mhw@netris.org>2020-07-31 13:38:40 -0400
commitd4c9e81c077688d13dffa52733c2a7f9a5b85965 (patch)
tree6f475f095a31a1de072971b2ee8c21cf4d8f4695
parent5eb97480f3652bb130513882e5e65fc95f98c043 (diff)
downloadguix-patches-d4c9e81c077688d13dffa52733c2a7f9a5b85965.tar
guix-patches-d4c9e81c077688d13dffa52733c2a7f9a5b85965.tar.gz
gnu: openimageio: Update to 2.0.13.
* gnu/packages/graphics.scm (openimageio): Update to 2.0.13. [inputs]: Replace python-2 with python-wrapper. Add pybind11 and robin-map.
-rw-r--r--gnu/packages/graphics.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index d5139b1f04..cc7e761955 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2019 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2019, 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
@@ -49,6 +49,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
@@ -624,7 +625,7 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
(define-public openimageio
(package
(name "openimageio")
- (version "1.8.17")
+ (version "2.0.13")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -633,7 +634,7 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
(file-name (git-file-name name version))
(sha256
(base32
- "0zq34szprgkrrayg5sl3whrsx2l6lr8nw4hdrnwv2qhn70jbi2w2"))))
+ "0czcls82v71wkw1syib16ncg7463hx0py0xclycsiv4w6i3wlkzz"))))
(build-system cmake-build-system)
;; FIXME: To run all tests successfully, test image sets from multiple
;; third party sources have to be present. For details see
@@ -650,7 +651,9 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
("giflib" ,giflib)
("openexr" ,openexr)
("ilmbase" ,ilmbase)
- ("python" ,python-2)
+ ("python" ,python-wrapper)
+ ("pybind11" ,pybind11)
+ ("robin-map" ,robin-map)
("zlib" ,zlib)))
(synopsis "C++ library for reading and writing images")
(description