summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-03 23:35:30 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:13 +0200
commitd340ee858f82c9e34da87deb2a62d27b22415959 (patch)
treea44a12b9353458e78729d439ca4ada55b467156a
parent5f4327df7fb03363f6cc0be9a97886aff6f76953 (diff)
downloadguix-patches-d340ee858f82c9e34da87deb2a62d27b22415959.tar
guix-patches-d340ee858f82c9e34da87deb2a62d27b22415959.tar.gz
gnu: ghc-edit-distance: Replace "--allow-newer" flag.
* gnu/packages/haskell.scm (ghc-edit-distance)[arguments]: Replace "--allow-newer" configure flag with a phase that patches the Cabal file.
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b6657f115f..ec262f143f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6208,7 +6208,13 @@ representations of current time.")
(base32 "0jkca97zyv23yyilp3jydcrzxqhyk27swhzh82llvban5zp8b21y"))))
(build-system haskell-build-system)
(arguments
- `(#:configure-flags (list "--allow-newer=QuickCheck")))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "edit-distance.cabal"
+ (("QuickCheck >= 2\\.4 && <2\\.9")
+ "QuickCheck >= 2.4 && < 2.12")))))))
(inputs
`(("ghc-random" ,ghc-random)
("ghc-test-framework" ,ghc-test-framework)