summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2021-05-21 02:51:02 +0000
committerRoel Janssen <roel@gnu.org>2021-05-21 12:34:33 +0200
commitd2e531fa4312c21ee2d6f252a4b98b2934fb5363 (patch)
treec7f8ff2d88ecc90441f955361d87949b4d8670f3
parent8b972bd53177dab0c5600f2b59d3ac0916ce82cf (diff)
downloadguix-patches-d2e531fa4312c21ee2d6f252a4b98b2934fb5363.tar
guix-patches-d2e531fa4312c21ee2d6f252a4b98b2934fb5363.tar.gz
gnu: Add numdiff.
* gnu/packages/maths.scm (numdiff): New variable.
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6b3f5cf41c..8cd64e7697 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6229,3 +6230,32 @@ and conversions, physical constants, symbolic calculations (including
integrals and equations), arbitrary precision, uncertainty propagation,
interval arithmetic, plotting.")
(license license:gpl2+)))
+
+(define-public numdiff
+ (package
+ (name "numdiff")
+ (version "5.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/numdiff/numdiff-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1vzmjh8mhwwysn4x4m2vif7q2k8i19x8azq7pzmkwwj4g48lla47"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'compress-documentation 'delete-precompressed-info-file
+ (lambda _
+ (delete-file (string-append (assoc-ref %outputs "out")
+ "/share/info/numdiff.info.gz"))
+ #t)))))
+ (home-page "https://nongnu.org/numdiff/")
+ (synopsis "Compare files with numeric fields")
+ (description
+ "Numdiff compares files line by line and field by field, ignoring small
+numeric differences and differences in numeric formats.")
+ (license license:gpl3+)))