summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-07-26 11:27:39 +0800
committer宋文武 <iyzsong@gmail.com>2015-07-26 11:27:39 +0800
commitcfbbff31cce0c95ae10f622959366f57b74d1b00 (patch)
treed1fd54be27d31e7d7aa680ce8c9b193f252d770a
parent65cb2d61e69c2ce20eee9790a5c355081785c1c0 (diff)
downloadguix-patches-cfbbff31cce0c95ae10f622959366f57b74d1b00.tar
guix-patches-cfbbff31cce0c95ae10f622959366f57b74d1b00.tar.gz
gnu: Add libatasmart.
* gnu/packages/freedesktop.scm (libatasmart): New variable.
-rw-r--r--gnu/packages/freedesktop.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 580096e6a5..9518ecf73c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -295,3 +295,26 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(description "Exempi is an implementation of the Extensible Metadata
Platform (XMP), which enables embedding metadata in PDF and image formats.")
(license license:bsd-3)))
+
+(define-public libatasmart
+ (package
+ (name "libatasmart")
+ (version "0.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://0pointer.de/public/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "138gvgdwk6h4ljrjsr09pxk1nrki4b155hqdzyr8mlk3bwsfmw31"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("udev" ,eudev)))
+ (home-page "http://0pointer.de/blog/projects/being-smart.html")
+ (synopsis "ATA S.M.A.R.T. reading and parsing library")
+ (description
+ "This library supports a subset of the ATA S.M.A.R.T. (Self-Monitoring,
+Analysis and Reporting Technology) functionality.")
+ (license license:lgpl2.1+)))