summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 13:56:16 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:45 +0200
commitced05db048ca60afe227acdcad9c794f231bf16d (patch)
treebdc341f0997fe0b341e1b279d21787757dfc9e62
parent5fb69a3bed439a59927db1d04f889c0a7a5b1188 (diff)
downloadguix-patches-ced05db048ca60afe227acdcad9c794f231bf16d.tar
guix-patches-ced05db048ca60afe227acdcad9c794f231bf16d.tar.gz
gnu: sbcl-cluffer: Remove bash reference from the closure.
* gnu/packages/lisp-xyz.scm (sbcl-cluffer)[arguments]: Unpatch shell shebangs. It's only needed to generate the documentation (which we should do at build-time by the way). This takes the closure size of cl-cluffer from 40 MiB down to 0 MiB.
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7c795ea4b9..1a8491a00f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11328,6 +11328,21 @@ sequences of objects.")
(build-system asdf-build-system/sbcl)
(inputs
(list sbcl-acclimation sbcl-clump))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'unpatch-shebangs
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The documentation Makefile rely on shell scripts.
+ ;; TODO: Build it!
+ ;; In the mean time, remove the shabang as it adds bash to the
+ ;; closure.
+ (let* ((out (assoc-ref outputs "out"))
+ (build-aux (string-append
+ out "/share/")))
+ (substitute* (find-files build-aux)
+ (("^#!.*/bin/sh") "#!/bin/sh")
+ (("^#!.*/bin/bash") "#!/bin/bash"))))))))
(home-page "https://github.com/robert-strandh/cluffer")
(synopsis "Common Lisp library providing a protocol for text-editor buffers")
(description "Cluffer is a library for representing the buffer of a text