summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-07-29 15:58:06 -0400
committerMark H Weaver <mhw@netris.org>2016-07-29 16:06:43 -0400
commitce290354ec4e97003be5f56042e55b36831818c1 (patch)
tree08deef478685ebac409d76ad4d68f3cef61d779a
parent814572aff53ced7a4c92192f5e7e682d1900de51 (diff)
downloadguix-patches-ce290354ec4e97003be5f56042e55b36831818c1.tar
guix-patches-ce290354ec4e97003be5f56042e55b36831818c1.tar.gz
gnu: gd: Add fix for gd2_read test.
* gnu/packages/patches/gd-fix-gd2-read-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gd.scm (gd)[source]: Add patch.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gd.scm3
-rw-r--r--gnu/packages/patches/gd-fix-gd2-read-test.patch14
3 files changed, 17 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a0d9b8fe11..473197078d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -514,6 +514,7 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-cross-environment-variables.patch \
%D%/packages/patches/gcc-libvtv-runpath.patch \
%D%/packages/patches/gcc-5.0-libvtv-runpath.patch \
+ %D%/packages/patches/gd-fix-gd2-read-test.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gegl-CVE-2012-4433.patch \
%D%/packages/patches/geoclue-config.patch \
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 153e1c7f8b..b1bbc22cd7 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -50,7 +50,8 @@
(sha256
(base32
"0g3xz8jpz1pl2zzmssglrpa9nxiaa7rmcmvgpbrjz8k9cyynqsvl"))
- (patches (search-patches "gd-fix-tests-on-i686.patch"))))
+ (patches (search-patches "gd-fix-gd2-read-test.patch"
+ "gd-fix-tests-on-i686.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/gd-fix-gd2-read-test.patch b/gnu/packages/patches/gd-fix-gd2-read-test.patch
new file mode 100644
index 0000000000..65f39e4426
--- /dev/null
+++ b/gnu/packages/patches/gd-fix-gd2-read-test.patch
@@ -0,0 +1,14 @@
+Fix a 'maybe-uninitialized' warning (turned error)
+which occurs on non-Intel platforms.
+
+--- libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-21 01:21:16.000000000 -0400
++++ libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-29 15:52:03.806405312 -0400
+@@ -5,7 +5,7 @@
+
+ int main(int argc, char *argv[])
+ {
+- int error, i = 0;
++ int error = 0, i = 0;
+ gdImagePtr im, exp;
+ FILE *fp;
+ char *path[] = {