summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-20 05:22:36 +0000
committerLars-Dominik Braun <lars@6xq.net>2021-05-08 11:27:48 +0200
commitce13e4a524b42f034220bdff116f4e9f5bf8be69 (patch)
tree64f48cdaff811778c30208df06a2832d6acb3279
parent4907d70898fe94233e7f27284d5a2432a739653b (diff)
downloadguix-patches-ce13e4a524b42f034220bdff116f4e9f5bf8be69.tar
guix-patches-ce13e4a524b42f034220bdff116f4e9f5bf8be69.tar.gz
gnu: Add python-pytest-qt.
* gnu/packages/python-check.scm (python-pytest-qt): New variable.
-rw-r--r--gnu/packages/python-check.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 01922b0d9d..15dbe65473 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
@@ -37,6 +37,7 @@
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (guix utils)
@@ -1084,6 +1085,42 @@ variables in the @file{pytest.ini} file.")
libraries.")
(license license:expat)))
+(define-public python-pytest-qt
+ (package
+ (name "python-pytest-qt")
+ (version "3.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-qt" version))
+ (sha256
+ (base32 "09c9psfn3zigpaw1l1cmynpa3csxa49wc2ih5lzl24skdkw0njvi"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "pytest"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-qpa
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
+ (propagated-inputs
+ `(("python-pyqt" ,python-pyqt)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/pytest-dev/pytest-qt")
+ (synopsis "Pytest support for PyQt and PySide applications")
+ (description
+ "@code{pytest-qt} is a Pytest plugin that allows programmers to write
+tests for PyQt5 and PySide2 applications.
+
+The main usage is to use the @code{qtbot} fixture, responsible for handling
+@code{qApp} creation as needed and provides methods to simulate user
+interaction, like key presses and mouse clicks.")
+ (license license:expat)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")