summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-09 11:41:08 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 23:43:32 +0200
commitcd42bad5d51d0069bceaea629f97bdc6154399da (patch)
treee6a1da0013e85c5630f97d69e6a8382f79df0518
parent7604d960ea2aefab32fbcaaa1484e0b63ea00bc2 (diff)
downloadguix-patches-cd42bad5d51d0069bceaea629f97bdc6154399da.tar
guix-patches-cd42bad5d51d0069bceaea629f97bdc6154399da.tar.gz
gnu: libcap: Update to 2.49.
* gnu/packages/linux.scm (libcap-2.31): Rename to ... (libcap): ... this: Update to 2.49. [arguments]: Adjust substitution. (libcap/next): Remove variable. * gnu/packages/avahi.scm (avahi)[inputs]: Change from LIBCAP/NEXT to LIBCAP. * gnu/packages/base.scm (coreutils)[inputs]: Likewise.
-rw-r--r--gnu/packages/avahi.scm2
-rw-r--r--gnu/packages/base.scm4
-rw-r--r--gnu/packages/linux.scm44
3 files changed, 9 insertions, 41 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index b2aeeadf47..602f9d7997 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -74,7 +74,7 @@
("expat" ,expat)
("gdbm" ,gdbm)
("glib" ,glib)
- ("libcap" ,libcap-2.31) ;to enable chroot support in avahi-daemon
+ ("libcap" ,libcap) ;to enable chroot support in avahi-daemon
("libdaemon" ,libdaemon)
("libevent" ,libevent)))
(native-inputs
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d7aca1f37a..33c4952415 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -339,8 +339,8 @@ used to apply commands with arbitrarily long arguments.")
,@(if (and (not (%current-target-system))
(member (%current-system)
(package-supported-systems libcap)))
- `(("libcap" ,libcap-2.31)) ;capability support in 'ls', etc.
- '())))
+ `(("libcap" ,libcap)) ;capability support in 'ls', etc.
+ '())))
(native-inputs
;; Perl is needed to run tests in native builds, and to run the bundled
;; copy of help2man. However, don't pass it when cross-compiling since
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0da13f214b..ce8219945d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2610,10 +2610,10 @@ network hardware types (plipconfig, slattach) and advanced aspects of IP
configuration (iptunnel, ipmaddr).")
(license license:gpl2+))))
-(define-public libcap-2.31
+(define-public libcap
(package
(name "libcap")
- (version "2.31")
+ (version "2.49")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2621,7 +2621,7 @@ configuration (iptunnel, ipmaddr).")
"libcap2/libcap-" version ".tar.xz"))
(sha256
(base32
- "0ikwm0kngrqa4ci80lqnrkk17kg09q7dxrz28y0gm5qw3vj8s266"))))
+ "10g13s1kihqpvrvmfl2w8s18icqjlz8hy2vkhz3jw2256vcw92z9"))))
(build-system gnu-build-system)
(arguments '(#:phases
(modify-phases %standard-phases
@@ -2629,10 +2629,9 @@ configuration (iptunnel, ipmaddr).")
;; Add $libdir to the RUNPATH of executables.
(lambda _
(substitute* "Make.Rules"
- (("LDFLAGS := #-g")
- (string-append "LDFLAGS := -Wl,-rpath="
- %output "/lib")))
- #t)))
+ (("LDFLAGS \\?= #-g")
+ (string-append "LDFLAGS ?= -Wl,-rpath="
+ %output "/lib"))))))
#:test-target "test"
#:make-flags (list "lib=lib"
(string-append "prefix="
@@ -2649,37 +2648,6 @@ Linux-based operating systems.")
;; License is BSD-3 or GPLv2, at the user's choice.
(license license:gpl2)))
-;; libcap 2.31 has problems with newer kernels, so provide this newer variant.
-;; Keep the old libcap around to avoid rebuilding 'coreutils' and 'avahi'.
-;; To be merged with libcap on the next rebuild cycle.
-(define-public libcap
- (package
- (inherit libcap-2.31)
- (version "2.45")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kernel.org/linux/libs/security/linux-privs/"
- "libcap2/libcap-" version ".tar.xz"))
- (sha256
- (base32
- "11ijmi7jik9iw6pdszc6bylhggghr8cza03bcrbhbqf0cpvkjrnn"))))
- (arguments
- (substitute-keyword-arguments (package-arguments libcap-2.31)
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'configure
- (lambda _
- ;; Add $libdir to the RUNPATH of executables.
- (substitute* "Make.Rules"
- (("LDFLAGS \\?= #-g")
- (string-append "LDFLAGS ?= -Wl,-rpath="
- %output "/lib")))
- #t))))))))
-
-(define-deprecated libcap/next libcap)
-(export libcap/next)
-
(define-public bridge-utils
(package
(name "bridge-utils")