summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-07 17:57:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-07 17:57:33 +0200
commitccaf29afd0b8093067dbf43d48e21d7a5e741006 (patch)
treeb7faa5e212b37b5b2eada75b6ae2904518897352
parente4cc6e0bb165968576890725707b388460ff501e (diff)
downloadguix-patches-ccaf29afd0b8093067dbf43d48e21d7a5e741006.tar
guix-patches-ccaf29afd0b8093067dbf43d48e21d7a5e741006.tar.gz
gnu: emacs-pyim-basedict: Update to 0.5.0.
* gnu/packages/emacs-xyz.scm (emacs-pyim-basedict): Update to 0.5.0.
-rw-r--r--gnu/packages/emacs-xyz.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed1f6f2b4a..869f8c3c7b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12740,24 +12740,26 @@ function to be used by other frontend programs.")
(license license:gpl2+)))
(define-public emacs-pyim-basedict
- (package
- (name "emacs-pyim-basedict")
- (version "0.3.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tumashu/pyim-basedict")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0576r8ap9gp91ycjf1d47pn13kxp0f9fysn09zlq44hr0s1y2y5d"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/tumashu/pyim-basedict")
- (synopsis "Input method dictionary of pyim")
- (description "Pyim-basedict is the default pinyin input method dictionary,
+ ;; XXX: The commit below points to the un-tagged 0.5.0 release.
+ (let ((commit "7495c974ada99f9fed96d8e85d8b97dabce9532c"))
+ (package
+ (name "emacs-pyim-basedict")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tumashu/pyim-basedict")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02asrh0adgjc5nn1ps7dq5zr38hkscnzc04sdpyjzvnmfcqsw7qb"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tumashu/pyim-basedict")
+ (synopsis "Input method dictionary of pyim")
+ (description "Pyim-basedict is the default pinyin input method dictionary,
containing words from the Rime project.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public emacs-pyim
(package