summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-03 14:59:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-03 15:05:44 +0200
commitcb51663a41e945cd70f9cf6c7d252c6c5136520d (patch)
treea8b2cb0c34e2dcbb1ed426abb02b00eb7df8b9ff
parentc4ac11f704086e5b35b1b513a81203f235a4bdd2 (diff)
downloadguix-patches-cb51663a41e945cd70f9cf6c7d252c6c5136520d.tar
guix-patches-cb51663a41e945cd70f9cf6c7d252c6c5136520d.tar.gz
gnu: keepassxc: Fix WRAP-QT-PROGRAM call.
* gnu/packages/password-utils.scm (keepassxc)[arguments]: Call WRAP-QT-PROGRAM with the expected arguments.
-rw-r--r--gnu/packages/password-utils.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index b79701851f..0b28a18d95 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -148,9 +148,9 @@ human.")
#:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-qt
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-qt-program (assoc-ref outputs "out") "keepassxc")
- #t)))))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-qt-program "keepassxc" #:output out #:inputs inputs)))))))
(native-inputs
`(("asciidoctor" ,ruby-asciidoctor)
("qttools" ,qttools)))