summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-16 18:44:20 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-08 10:33:07 +0100
commitcb09ac57b4ba1a3ebc641914c6c91a1054088a21 (patch)
tree467abecce84e0a2c3c15841b00670ec4be566717
parentefa773f94a18b40f2c63795f364ae87dade76f60 (diff)
downloadguix-patches-cb09ac57b4ba1a3ebc641914c6c91a1054088a21.tar
guix-patches-cb09ac57b4ba1a3ebc641914c6c91a1054088a21.tar.gz
gnu: Add rust-cipher-0.2.
* gnu/packages/crates-io.scm (rust-cipher-0.2): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e3571ab595..f379c375de 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5543,6 +5543,32 @@ chain, the first matching branch is the item that gets emitted.")
(description "This package provides Rust bindings for libclang.")
(license license:asl2.0)))
+(define-public rust-cipher-0.2
+ (package
+ (name "rust-cipher")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cipher" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "00b8imbmdg7zdrbaczlivmdfdy09xldg95wl4iijl15xgjcfgy0j"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-blobby" ,rust-blobby-0.3)
+ ("rust-generic-array" ,rust-generic-array-0.14))))
+ (home-page "https://docs.rs/cipher/")
+ (synopsis "Traits for describing block ciphers and stream ciphers")
+ (description "This package provides traits which define the functionality
+of block ciphers and stream ciphers. See RustCrypto/block-ciphers and
+RustCrypto/stream-ciphers for algorithm implementations which use these
+traits.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-clang-sys-0.29
(package
(inherit rust-clang-sys-1)