summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-12 21:50:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-12 21:50:42 +0200
commitc9a16728410f11f4bd9b49632ca2b13df849ecdc (patch)
tree70ebc29aaf03eda9d3802acd326f886930ad74a0
parent73092df4686074572e79a54946d9b62f495f58a7 (diff)
downloadguix-patches-c9a16728410f11f4bd9b49632ca2b13df849ecdc.tar
guix-patches-c9a16728410f11f4bd9b49632ca2b13df849ecdc.tar.gz
gnu: Add python-conda-package-handling.
* gnu/packages/package-management.scm (python-conda-package-handling): New variable.
-rw-r--r--gnu/packages/package-management.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 9c2c226086..325007ac76 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -728,6 +728,60 @@ environments.")
(define-public python2-anaconda-client
(package-with-python2 python-anaconda-client))
+(define-public python-conda-package-handling
+ (package
+ (name "python-conda-package-handling")
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/conda/conda-package-handling/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bqbs6a8jbjmbn47n5n1p529cx7pf4vgfnhqca9mflgidfb5i0jf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-unmodified-libarchive
+ (lambda _
+ (substitute* "setup.py"
+ (("archive_and_deps") "archive"))
+ #t))
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "tests"
+ "-k"
+ (string-append
+ ;; TODO: these three fail because the mocker fixture
+ ;; cannot be found
+ "not test_rename_to_trash"
+ " and not test_api_extract_tarball_with_libarchive_import_error"
+ " and not test_delete_trash"
+ ;; TODO: this one does not raise an exception when it
+ ;; should.
+ " and not test_secure_refusal_to_extract_abs_paths")))))))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-tqdm" ,python-tqdm)))
+ (inputs
+ `(("libarchive" ,libarchive)))
+ (native-inputs
+ `(("python-cython" ,python-cython)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-mock" ,python-mock)))
+ (home-page "https://conda.io")
+ (synopsis "Create and extract conda packages of various formats")
+ (description
+ "This library is an abstraction of Conda package handling and a tool for
+extracting, creating, and converting between formats.")
+ (license license:bsd-3)))
+
(define-public python-conda
(package
(name "python-conda")