summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-12-01 00:18:47 -0600
committerEric Bavier <bavier@member.fsf.org>2014-12-09 12:02:08 -0600
commitc7518b04f0a3487f6c0885779395ed1b1eaffa36 (patch)
tree45e0d7c4b247fd25d8bd73688697104b09faaed4
parent7850f47ac5ad53ebd68c9018f6f5db57a5ae5f3b (diff)
downloadguix-patches-c7518b04f0a3487f6c0885779395ed1b1eaffa36.tar
guix-patches-c7518b04f0a3487f6c0885779395ed1b1eaffa36.tar.gz
gnu: Add perl-ipc-run3.
* gnu/packages/perl.scm (perl-ipc-run3): New variable.
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 430c6b5b9a..cdac13dcac 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -228,3 +228,27 @@ Module::Build project, but has been externalized here for general use.")
(home-page (string-append "http://search.cpan.org/~kwilliams/"
"Probe-Perl-" version))
(license (package-license perl))))
+
+(define-public perl-ipc-run3
+ (package
+ (name "perl-ipc-run3")
+ (version "0.048")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
+ "IPC-Run3-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r9m8q78bg7yycpixd7738jm40yz71p2q7inm766kzsw3g6c709x"))))
+ (build-system perl-build-system)
+ (synopsis "Run a subprocess with input/ouput redirection")
+ (description
+ "The IPC::Run3 module allows you to run a subprocess and redirect stdin,
+stdout, and/or stderr to files and perl data structures. It aims to satisfy
+99% of the need for using system, qx, and open3 with a simple, extremely
+Perlish API and none of the bloat and rarely used features of IPC::Run.")
+ (home-page (string-append "http://search.cpan.org/~rjbs/"
+ "IPC-Run3-" version))
+ ;; "You may use this module under the terms of the BSD, Artistic, or GPL
+ ;; licenses, any version."
+ (license (list bsd-3 gpl3+))))