summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:51:41 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:53:22 +0100
commitc3163fe6b4265d8626f1794c40abdfab39721104 (patch)
treef4c6543c4e93b88b457c453a6b386b371d498bcb
parentca3913d1f8d0582236989e516dc61ed38eec6ed9 (diff)
downloadguix-patches-c3163fe6b4265d8626f1794c40abdfab39721104.tar
guix-patches-c3163fe6b4265d8626f1794c40abdfab39721104.tar.gz
gnu: Add r-textplot.
* gnu/packages/cran.scm (r-textplot): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 91cf7c550d..5854ff6031 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -28076,3 +28076,30 @@ Xiaohui Yan, Jiafeng Guo, Yanyan Lan, Xueqi Cheng (2013)
@url{https://github.com/xiaohuiyan/xiaohuiyan.github.io/blob/master/paper/\
BTM-WWW13.pdf}.")
(license license:asl2.0)))
+
+(define-public r-textplot
+ (package
+ (name "r-textplot")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "textplot" version))
+ (sha256
+ (base32
+ "1sgkndy2cxk8c76h8hwajn6f78w5jj2n8vsmaxh9kj931crzn8cy"))))
+ (properties `((upstream-name . "textplot")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-lattice" ,r-lattice)
+ ("r-matrix" ,r-matrix)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/bnosac/textplot")
+ (synopsis "Text Plots")
+ (description
+ "Visualise complex relations in texts. This is done by providing
+functionalities for displaying text co-occurrence networks, text correlation
+networks, dependency relationships as well as text clustering. Feel free to
+join the effort of providing interesting text visualisations.")
+ (license license:gpl2)))