summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-09-17 10:33:28 +0100
committerBen Woodcroft <donttrustben@gmail.com>2016-09-27 20:06:00 +1000
commitc2efe1aea8e17b5b59a964623857008931fc352a (patch)
tree073f793fb08320c018fe7d951d2c6e828395ec98
parentfd49eb213f53e6030d94f8b50446b5985952c380 (diff)
downloadguix-patches-c2efe1aea8e17b5b59a964623857008931fc352a.tar
guix-patches-c2efe1aea8e17b5b59a964623857008931fc352a.tar.gz
gnu: Add python-pyxb.
* gnu/packages/xml.scm (python-pyxb, python2-pyxb): New variables.
-rw-r--r--gnu/packages/xml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 7befad54aa..cd3426b55f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -729,6 +730,30 @@ different Unicode encodings which happen automatically during
parsing/saving.")
(license license:expat)))
+(define-public python-pyxb
+ (package
+ (name "python-pyxb")
+ (version "1.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyXB" version))
+ (sha256
+ (base32
+ "0rzzwibfqa28gxgcxx4cybx1qcg0g6fand06ykj3gz7z5kp653sf"))))
+ (build-system python-build-system)
+ (home-page "http://pyxb.sourceforge.net/")
+ (synopsis "Python XML Schema Bindings")
+ (description
+ "PyXB (\"pixbee\") is a pure Python package that generates Python source
+code for classes that correspond to data structures defined by XMLSchema.")
+ (license (list license:asl2.0 ; Most files.
+ license:expat ; pyxb/utils/six.py
+ license:gpl2 ; bundled jquery in doc is dual MIT/GPL2
+ license:psfl)))) ; pyxb/utils/activestate.py
+
+(define-public python2-pyxb
+ (package-with-python2 python-pyxb))
+
(define-public xmlto
(package
(name "xmlto")