summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 11:39:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 11:44:37 +0200
commitc2bb0beef7d67f56aaa35f6d0969084b999bdd30 (patch)
treecad9d3dfa44e4172fe537954c08b28e79d3ae1a0
parent78280e2e4a749a980886b71a5ac911193c370267 (diff)
downloadguix-patches-c2bb0beef7d67f56aaa35f6d0969084b999bdd30.tar
guix-patches-c2bb0beef7d67f56aaa35f6d0969084b999bdd30.tar.gz
gnu: Add python-azure-core.
* gnu/packages/python-web.scm (python-azure-core): New variable.
-rw-r--r--gnu/packages/python-web.scm67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5c03ec1544..eb94cb3de6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6646,6 +6646,73 @@ communicate with Microsoft Azure Storage services.")
Python.")
(license license:expat)))
+(define-public python-azure-core
+ (package
+ (name "python-azure-core")
+ (version "1.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "azure-core" version ".zip"))
+ (sha256
+ (base32 "1r8bpn3zz02mj00qbaks5qq49wqd3mznkm90bchd1mxa3w21nnrl"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ ;; This fails because devtools_testutils doesn't exist.
+ (delete-file "tests/test_connection_string_parsing.py")
+ ;; Needs network.
+ (for-each delete-file
+ '("tests/async_tests/test_streaming_async.py"
+ "tests/test_streaming.py"))
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) "/tests/testserver_tests/coretestserver:"
+ (getenv "GUIX_PYTHONPATH")))
+ (invoke "pytest"
+ ;; Most of these need network access.
+ "-m" "not asyncio and not live_test_only"
+ "-k"
+ ;; These need network access.
+ (string-append
+ "not test_example_raw_response_hook"
+ " and not test_example_headers_policy"
+ " and not test_example_request_id_policy"
+ " and not test_example_user_agent_policy"
+ " and not test_example_requests"
+ " and not test_example_pipeline"
+ " and not test_example_pipeline_client"
+ " and not test_example_redirect_policy"
+ " and not test_example_no_redirects"
+ " and not test_example_retry_policy"
+ " and not test_example_no_retries"
+ " and not test_decompress_plain_no_header"
+ " and not test_compress_plain_no_header"
+ " and not test_decompress_compressed_no_header"))))))))
+ (propagated-inputs
+ (list python-aiohttp
+ python-requests
+ python-six
+ python-trio
+ python-typing-extensions))
+ (native-inputs
+ (list python-flask
+ python-msrest
+ python-pytest
+ python-pytest-aiohttp
+ python-pytest-asyncio
+ python-pytest-trio
+ unzip))
+ (home-page "https://github.com/Azure/azure-sdk-for-python")
+ (synopsis "Microsoft Azure Core library for Python")
+ (description "This package provides the Microsoft Azure Core library for
+Python.")
+ (license license:expat)))
+
(define-public python-w3lib
(package
(name "python-w3lib")